Can not deploy to JBoss 7: Artifact XXX:war exploded: Server is not connected. Deploy is not available.

Hi,
While evaluating IDEA 12.1 I encountered this error: Artifact XXX:war exploded: Server is not connected. Deploy is not available.
I created simple JSF application, created new local jboss configuration, added deployment (exploded war) and started debugging.

Also, I can not stop the server from the IDE, just pressing "Strop" button do not work, pressing "kill" button helps.

In IntelliJ IDEA Logs I see the following exception:

2013-04-20 14:15:53,267 [2049589]  DEBUG - erver.JavaeeServerInstanceImpl -  
java.io.IOException: java.net.ConnectException: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out
 at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:139)
 at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:81)
 at com.intellij.javaee.oss.jboss.agent.JBoss7Agent$Operation.executeOrFail(JBoss7Agent.java:146)
 at com.intellij.javaee.oss.jboss.agent.JBoss7Agent$Operation.execute(JBoss7Agent.java:135)
 at com.intellij.javaee.oss.jboss.agent.JBoss71Agent$1.validate(JBoss71Agent.java:25)
 at com.intellij.javaee.oss.jboss.agent.JBoss7Agent.doConnect(JBoss7Agent.java:30)
 at com.intellij.javaee.oss.agent.SimpleAgentBase$1.doJob(SimpleAgentBase.java:21)
 at com.intellij.javaee.oss.agent.SimpleAgentBase$1.doJob(SimpleAgentBase.java:17)
 at com.intellij.javaee.oss.agent.SimpleAgentJob.perform(SimpleAgentJob.java:16)
 at com.intellij.javaee.oss.agent.SimpleAgentBase.connect(SimpleAgentBase.java:17)


but running
lsof -Pni | grep 9999

gives output:

idea       813 dima  279u  IPv4 0xf4fdc73d66362561      0t0  TCP 127.0.0.1:51459->127.0.0.1:9999 (ESTABLISHED)
idea       813 dima  280u  IPv4 0xf4fdc73d64bef7e9      0t0  TCP 127.0.0.1:51462->127.0.0.1:9999 (ESTABLISHED)
idea       813 dima  282u  IPv4 0xf4fdc73d6873c561      0t0  TCP 127.0.0.1:51465->127.0.0.1:9999 (ESTABLISHED)
idea       813 dima  283u  IPv4 0xf4fdc73d69f007e9      0t0  TCP 127.0.0.1:51467->127.0.0.1:9999 (ESTABLISHED)
java      1008 dima  284u  IPv6 0xf4fdc73d64bea399      0t0  TCP 127.0.0.1:9999 (LISTEN)

and amount of lines like "idea       813 dima  279u  IPv4 0xf4fdc73d66362561      0t0  TCP 127.0.0.1:51459->127.0.0.1:9999 (ESTABLISHED)"
increasing with the time

I use Mac OS 10.8.3

Also, I attach idea.log

Thanks.


Attachment(s):
Archive.zip
21 comments
Official comment

@Glauber Matos

Please note that message " ... Server is not connected. Deploy is not available" could appear at server's startup and just states the initial state before the connect. 
 
It only becomes a problem if the connection never happens, but in this case IDEA should display more information about the connection issues (like for example in the original message in this thread). 
 
If possible please
- set Subsystem to J2EE.JBoss to ensure I am notified
- attach full idea.log and complete output from the Run console
 
Thanks 
 
 

Hello,

Have you modified your JBoss configuration somehow?
Please attach <JBoss home>/standalone/configuration/standalone.xml here or in new youtrack (there is an option to make attached files visible "for IDEA developers only").
Also, try to launch the JBoss run configuration with the firewall switched off (if there's any).

Regards,
Michael

0

Hello,
Thanks for reply.
No, I did not modified JBoss configuration that can affect management interface...
I attach standalone.xml config from my JBoss.
Also, I do not have firewall enabled.
Thank you



Attachment(s):
standalone.xml
0

Hello,

1) Is the issue reproducable in Debug mode only? Or in Run mode as well?
2) try to specify:
2.1) '-b 127.0.0.1' as the command line arguments of the startup script
- - go to 'Startup/Connection' tab of the run configuration
- - uncheck 'Use default' for the 'Startup script'
- - add '-b 127.0.0.1' after the '...standalone.sh'
2.2) '-Djboss.bind.address.management=127.0.0.1' as the VM option -
add this to the 'VM options' field of the 'Server' tab of the run configuration
3) try to switch off proxy (if some was selected in IDEA) -- go to 'HTTP proxy' section of the IDEA settings and choose 'No proxy'

Regards
Michael

1

Hello,
Thanks for reply,

  1. The issue is reproducable both in Run and Debug mode

    1. -b 127.0.0.1 (and -b 0.0.0.0) not helps (both in Run and Debug mode)
    2. -Djboss.bind.address.management=127.0.0.1 not helps too...
  2. HTTP proxy is not in use


Also tried to download fresh installation of JBoss 7.1.1.Final from http://download.jboss.org/jbossas/7.1/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final.zip with no success... the same error

The issue still exists...

0

Issue resolved by installing latest JDK 1.7.0.21

0

same problem with Wildfly (Jboss 8), Idea 12 and jdk 1.7.0_40-b43 on Mac. any hints how to solve it?

cheers,
michał

1

Have you tried to update to latest JDK? Can you make sure that JBoss and IDEA are using the same Java version?

0

I've just upgraded java to 1.7.0_45-b18 (and enforced JAVA_HOME for jboss) and unfortunately there is still an issue. This is what I get from Idea console:

/Users/michal/java/wildfly-8.0.0.Beta1/bin/standalone.sh
[2013-10-28 11:41:40,639] Artifact sample:war exploded: Server is not connected. Deploy is not available.
Detected server admin port: 9999
Detected server http port: 8080
=========================================================================


  JBoss Bootstrap Environment


  JBOSS_HOME: /Users/michal/java/wildfly-8.0.0.Beta1


  JAVA: /Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home/bin/java


  JAVA_OPTS:  -server -XX:+UseCompressedOops -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true


=========================================================================


11:41:41,142 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.0.Final
11:41:41,391 INFO  [org.jboss.msc] (main) JBoss MSC version 1.2.0.Beta2
11:41:41,465 INFO  [org.jboss.as] (MSC service thread 1-6) JBAS015899: WildFly 8.0.0.Beta1 "WildFly" starting
11:41:42,319 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
11:41:42,321 INFO  [org.xnio] (MSC service thread 1-5) XNIO version 3.1.0.CR7
11:41:42,328 INFO  [org.xnio.nio] (MSC service thread 1-5) XNIO NIO Implementation Version 3.1.0.CR7
11:41:42,342 INFO  [org.jboss.remoting] (MSC service thread 1-5) JBoss Remoting version 4.0.0.Beta1
11:41:42,357 INFO  [org.jboss.as.security] (ServerService Thread Pool -- 46) JBAS013171: Activating Security Subsystem
11:41:42,362 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 33) JBAS010280: Activating Infinispan subsystem.
11:41:42,368 INFO  [org.jboss.as.naming] (ServerService Thread Pool -- 41) JBAS011800: Activating Naming Subsystem
11:41:42,369 INFO  [org.jboss.as.security] (MSC service thread 1-11) JBAS013170: Current PicketBox version=4.0.17.SP1
11:41:42,371 INFO  [org.jboss.as.jsf] (ServerService Thread Pool -- 39) JBAS012605: Activated the following JSF Implementations: [main]
11:41:42,403 INFO  [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017502: Undertow 1.0.0.Beta17 starting
11:41:42,403 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-3) JBAS017502: Undertow 1.0.0.Beta17 starting
11:41:42,403 INFO  [org.jboss.as.webservices] (ServerService Thread Pool -- 50) JBAS015537: Activating WebServices Extension
11:41:42,430 INFO  [org.jboss.as.connector.logging] (MSC service thread 1-9) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.0.Final)
11:41:42,432 INFO  [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 28) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
11:41:42,441 INFO  [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-8) JBAS010417: Started Driver service with driver-name = h2
11:41:42,445 INFO  [org.jboss.as.naming] (MSC service thread 1-9) JBAS011802: Starting Naming Service
11:41:42,448 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-11) JBAS015400: Bound mail session [java:jboss/mail/Default]
11:41:42,503 INFO  [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017527: Creating file handler for path /Users/michal/java/wildfly-8.0.0.Beta1/welcome-content
11:41:42,511 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-6) JBAS017525: Started server default-server.
11:41:42,515 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-11) JBAS017531: Host default-host starting
11:41:42,605 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-3) JBAS017519: Undertow HTTP listener default listening on /127.0.0.1:8080
11:41:43,012 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-3) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
11:41:43,032 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-2) JBAS015012: Started FileSystemDeploymentService for directory /Users/michal/java/wildfly-8.0.0.Beta1/standalone/deployments
11:41:43,036 INFO  [org.jboss.as.remoting] (MSC service thread 1-9) JBAS017100: Listening on 127.0.0.1:9999
11:41:43,040 INFO  [org.jboss.ws.common.management] (MSC service thread 1-12) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.2.1.Final
11:41:43,136 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
11:41:43,136 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
11:41:43,137 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.0.0.Beta1 "WildFly" started in 2306ms - Started 180 of 217 services (62 services are lazy, passive or on-demand)

0

Ok, problem solved. Idea was running still on JDK 1.6. after changing to 1.7 deployments started working. at last :)

thanks for hints!

0

My team is having the same issue (across several machines.)  Setup is:

Windows 7 64bit
IDEA 13.0.2 - 64bit exe
JDK 1.7.0_45-b18 64bit (only JDK installed on machine)
JBoss 7.2.0.Final

1. Issue happens in run and debug modes.
2. using bind addresses -b 0.0.0.0 or 127.0.0.1 does not affect the outcome
3. no proxy

JBoss will run if you add the war file manually to the standalone\deployments folder, and execute standalone.bat.

First few lines on output when running within IntelliJ

C:\devel\jboss-as-7.2.0.Final\bin\standalone.bat
[2014-03-12 12:16:22,636] Artifact web: Server is not connected. Deploy is not available.
Detected server admin port: 9999
Detected server http port: 8100

Some people seem to attribute this issue to IDEA running under a different JDK.  In our case, I can confirm that IDEA is running the above JDK (help->about) says JDK 1.7.0_45-b18, while the JBoss output confirms

===============================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: C:\devel\jboss-as-7.2.0.Final

  JAVA: C:\Program Files\Java\jdk1.7.0_45\bin\java

  JAVA_OPTS: -XX:+TieredCompilation -XX:+UseCompressedOops -Dprogram.name=standalone.bat -Xms1024m -Xmx1024m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djboss.server.default.config=standalone.xml -Djboss.node.name=BXTPC -Djboss.server.log.dir=

===============================================================================


Here are the interfaces and socket-bindings from standalone.xml

    <interfaces>
        <interface name="management">
            <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
        </interface>
        <interface name="public">
            <inet-address value="${jboss.bind.address:127.0.0.1}"/>
        </interface>
        <interface name="unsecure">
            <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
        </interface>
    </interfaces>

    <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
        <socket-binding name="management-native" interface="management" port="${jboss.management.http.port:9999}"/>
        <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
        <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
        <socket-binding name="ajp" port="8009"/>
        <socket-binding name="http" port="8080"/>
        <socket-binding name="https" port="8443"/>
        <socket-binding name="osgi-http" interface="management" port="8090"/>
        <socket-binding name="remoting" port="4447"/>
        <socket-binding name="txn-recovery-environment" port="4712"/>
        <socket-binding name="txn-status-manager" port="4713"/>
        <outbound-socket-binding name="mail-smtp">
            <remote-destination host="localhost" port="25"/>
        </outbound-socket-binding>
    </socket-binding-group>

The current setup works with JBoss 7.1.1.Final, but not with JBoss 7.2.0.Final.

Any thoughts or ideas are appreciated.

Bill

0

Hello,

Do you have JBoss EAP 6.1.0 (available at http://www.jboss.org/jbossas/downloads/) as the JBoss 7.2.0?
If it's another installation, could you please provide a link to download?

Also, it is strange that IDEA detects http port number as 8100, while it looks like defined as 8080 in standalone.xml.
So, could you please attach (here or better in new youtrack for JavaEE.Jboss subsystem):
1) complete standalone.xml
2) complete content of the Output tab of the IDEA JBoss run configuration
3) .idea subfolder or your project folder.

Regards,
Michael

0

Thanks for the reply Michael.

We are not using EAP, rather JBoss 7.2.0.Final build from source (GIT) over at https://github.com/wildfly/wildfly.  JBoss has stopped distributing downloads after JBoss 7.1.1.Final, but they are still available from source.

Anyway, I was able to get this working, and the issue was not IntelliJ.  Rather it was an issue with the standalone.xml, just not where I was looking.  We had some problems creap into this section when we moved from 7.1.1.Final to 7.2.0.Final.

    <management>
        <security-realms>
            <security-realm name="ManagementRealm">
                <authentication>
                    <local default-user="$local"/>
                    <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                </authentication>
            </security-realm>
            <security-realm name="ApplicationRealm">
                <authentication>
                    <local default-user="$local" allowed-users="*"/>
                    <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                </authentication>
                <authorization>
                    <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
                </authorization>
            </security-realm>
        </security-realms>
        <management-interfaces>
            <native-interface security-realm="ManagementRealm">
                <socket-binding native="management-native"/>
            </native-interface>
            <http-interface security-realm="ManagementRealm">
                <socket-binding http="management-http"/>
            </http-interface>
        </management-interfaces>
    </management>


Basically, our settings in 7.1.1.Final did not have the lines <local... So we set up JBoss 7.2.0.Final with the settings below:

    <management>
        <security-realms>
            <security-realm name="ManagementRealm">
                <authentication>
                    <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                </authentication>
            </security-realm>
            <security-realm name="ApplicationRealm">
                <authentication>
                    <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                </authentication>
            </security-realm>
        </security-realms>
        <management-interfaces>
            <native-interface security-realm="ManagementRealm">
                <socket-binding native="management-native"/>
            </native-interface>
            <http-interface security-realm="ManagementRealm">
                <socket-binding http="management-http"/>
            </http-interface>
        </management-interfaces>
    </management>


it seems like these were enough to make the management console inaccessible to IntelliJ for some reason.

Anyway, thank you for your response.  Hopefully this helps someone else!

0

Hello,

This thread is over an year old but I am facing similar issue using IDEA 12.1 Utimate edition and unable to resolve it.

I am upgrading my application from JBOSS AS 7.1 running on Java 6 to WildFly 8.2 Final running on Java 8. I am using IDEA 11.1.5 Ultimate edition when I realized that this has a bug and does not recognise the JBOSS webserver AS 7.2  onwards as valid server.

So I switched to IDEA 14.1 Utlimate edition evaluation version. I had successfully migrated my application to WildFly 8.2 Final with JDK 8. However the trial version I was evaluating expired. I found issue with IDEA in recognising JBOSS AS 7.2 was fixed with version 12.1 onwards and I happen to have license for same. So I uninstalled the 14.1 version and switched to 12.1. However when running the WildFly server from Intellij IDEA, it does deploy the artifacts. Following is the last log I see and there are no errors.

JBAS015874: WildFly 8.2.0.Final "WildFly" started in 2306ms - Started 180 of 217 services (62 services are lazy, passive or on-demand)

At the moment I am completely clueless as to what is the issue here. I have tried matching (as suggested in this thread) the IDEA JDK to match that of server which is jdk1.8.0_45. However this did not help. Does any one know if there any known isues with IDEA 12.1 and Java 8?

Thanks.

Regards,
Nitin

0

Hello,

Does deploy to WildFly work from IDEA 14.1 for you?

0

Hello,

Yes it works fine on 14.1 but not on 12.1.

Regards,
Nitin

0

Hello

We only backport the fixes into the previous released version, and there were quite a lot of the youtrack's fixed for JBoss / WildFly since 2012.
So even if we (re-)found your exact problem we still would not have a means to provide you with the solution.

One may think about using the plugin jars from IDEA 14 in the earlier version but I doubt it will really work due to the binary incompatibilities.
You may also try the IDEA 15 EAPs at https://confluence.jetbrains.com/display/IDEADEV/IDEA+15+EAP or update your subscription.

HTH
Michael

0

Hello I'm facing the same problem. When I tried to start an app with Jboss EAP the console prints this message: Artifact xxx:war exploded: Server is not connected. Deploy is not available.

The problem ocurrs on run and debug mode

I'm using:
jdk1.8.0_45
Jboss EAP 6.4
I've pointed IDEA_JDK_64 env to same path of JBoss JDK
Windows 10

Jboss command line arg:
c:\programas\jboss-eap-6.4\bin\standalone.bat -b 0.0.0.0

Jvm Parameters:
-Xms1024m
-Xmx1024m
-XX:MaxPermSize=256m
-Djboss.bind.address.management=myComputerName
-Dorg.jboss.resolver.warning=true
-Djava.net.preferIPv4Stack=true
-Dsun.rmi.dgc.client.gcInterval=3600000
-Dsun.rmi.dgc.server.gcInterval=3600000
-Djboss.modules.system.pkgs=org.jboss.byteman
-Djava.awt.headless=true
-Dspring.profiles.active="desenv-securitys,desenvolvimento"
-Dorg.jboss.logmanager.nocolor=true
-Djboss.home.dir=c:/Programas/jboss-eap-6.4


Some standalone.xml configs:

<interfaces>
<interface name="management">
<inet-address value="${jboss.bind.address.management:0.0.0.0}"/>
</interface>
<interface name="public">
<inet-address value="${jboss.bind.address:0.0.0.0}"/>
</interface>
<interface name="unsecure">
<inet-address value="${jboss.bind.address.unsecure:0.0.0.0}"/>
</interface>
</interfaces>

<socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
<socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
<socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
<socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
<socket-binding name="ajp" port="8009"/>
<socket-binding name="http" port="8080"/>
<socket-binding name="https" port="8443"/>
<socket-binding name="remoting" port="4447"/>
<socket-binding name="txn-recovery-environment" port="4712"/>
<socket-binding name="txn-status-manager" port="4713"/>
<outbound-socket-binding name="mail-smtp">
<remote-destination host="localhost" port="25"/>
</outbound-socket-binding>
</socket-binding-group>

<management>
<security-realms>
<security-realm name="ManagementRealm">
<authentication>
<local default-user="$local" skip-group-loading="true"/>
<properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
</authentication>
<authorization map-groups-to-roles="false">
<properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>
</authorization>
</security-realm>
<security-realm name="ApplicationRealm">
<authentication>
<local default-user="$local" allowed-users="*" skip-group-loading="true"/>
<properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
</authentication>
<authorization>
<properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
</authorization>
</security-realm>
</security-realms>
<audit-log>
<formatters>
<json-formatter name="json-formatter"/>
</formatters>
<handlers>
<file-handler name="file" formatter="json-formatter" path="audit-log.log" relative-to="jboss.server.data.dir"/>
</handlers>
<logger log-boot="true" log-read-only="false" enabled="false">
<handlers>
<handler name="file"/>
</handlers>
</logger>
</audit-log>
<management-interfaces>
<native-interface security-realm="ManagementRealm">
<socket-binding native="management-native"/>
</native-interface>
<http-interface security-realm="ManagementRealm">
<socket-binding http="management-http"/>
</http-interface>
</management-interfaces>
<access-control provider="simple">
<role-mapping>
<role name="SuperUser">
<include>
<user name="$local"/>
</include>
</role>
</role-mapping>
</access-control>
</management>

Intellij Console Messages:

C:\Programas\jboss-eap-6.4\bin\standalone.bat -b 0.0.0.0
Calling "C:\Programas\jboss-eap-6.4\bin\standalone.conf.bat"
"JAVA_OPTS already set in environment; overriding default settings with values: -Xms1024m -Xmx1024m -XX:MaxPermSize=256m -Djboss.bind.address.management=myComputerName -Dorg.jboss.resolver.warning=true -Djava.net.preferIPv4Stack=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Dspring.profiles.active=desenv-securitys,desenvolvimento -Dorg.jboss.logmanager.nocolor=true -Djboss.home.dir=C:/Programas/jboss-eap-6.4 "
Setting JAVA property to "C:\Program Files\Java\jdk1.8.0_45\bin\java"
===============================================================================

JBoss Bootstrap Environment

JBOSS_HOME: "C:\Programas\jboss-eap-6.4"

JAVA: "C:\Program Files\Java\jdk1.8.0_45\bin\java"

JAVA_OPTS: "-verbose:gc -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=3M -XX:-TraceClassUnloading -XX:+UseCompressedOops -Dprogram.name=standalone.bat -Xms1024m -Xmx1024m -XX:MaxPermSize=256m -Djboss.bind.address.management=myComputerName -Dorg.jboss.resolver.warning=true -Djava.net.preferIPv4Stack=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Dspring.profiles.active=desenv-securitys,desenvolvimento -Dorg.jboss.logmanager.nocolor=true -Djboss.home.dir=C:/Programas/jboss-eap-6.4 "

===============================================================================

"C:\Program Files\Java\jdk1.8.0_45\bin\java" -classpath "C:\Program Files (x86)\JetBrains\IntelliJ IDEA 2016.3\lib\idea_rt.jar;C:\Program Files (x86)\JetBrains\IntelliJ IDEA 2016.3\lib\util.jar" -Dfile.encoding=windows-1252 com.intellij.rt.execution.CommandLineWrapper C:\Users\glauber.matos\AppData\Local\Temp\classpath com.intellij.javaee.oss.process.JavaeeProcess 51078 com.intellij.javaee.oss.jboss.agent.JBoss71Agent
[2016-12-12 09:44:20,248] Artifact xxx1:war exploded: Server is not connected. Deploy is not available.
[2016-12-12 09:44:20,248] Artifact xxx2:war exploded: Server is not connected. Deploy is not available.
Detected server admin port: 9999
Detected server http port: 8080

Thanks.

0

I forgot to put the Intellij Version in previous comment:

IntelliJ IDEA 2016.3
Build #IU-163.7743.44, built on November 17, 2016
JRE: 1.8.0_45-b15 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation

0

@Glauber Matos

Please note that message " ... Server is not connected. Deploy is not available" could appear at server's startup and just states the initial state before the connect.
 
It only becomes a problem if the connection never happens, but in this case IDEA should display more information about the connection issues (like for example in the original message in this thread).
 
Could you please
- set subsystem to JavaEE.JBoss to ensure I am notified 
- attach full idea.log and complete output from the Run console there
 
 
0

There is already a youtrack to this issue, so I registered my comments with respective idea.log in IDEA-161569. 

0

Please sign in to leave a comment.