Flex Project Multiple SDKs

I am having a very wierd issue with multiple modules and dependencies in IntelliJ with a flex project. Here is the situation.

I have a module that is using flex_sdk_4.5.1.21328_air_3.0b2 the latest AIR SDK with Stage3D.
I have a core module that is using flex_sdk_4.5.1.21328_air_2.7 current AIR SDK. This module does not require any 3d stuff and is purely a core set of classes for projects.

Since the Module using AIR 3.0 beta depends on the module using AIR2.7 IntelliJ is not finding the stage3Ds property on stage.
When I remove the Module dependency this error goes away. Is there a reason I cannot use multiple SDK's across projects?

If i can give any more information please let me know

thanks,
-ross

2 comments
Comment actions Permalink

Do you mean errors in highlighting or in compilation? Different SDKs for different IDEA modules are allowed. But you should use mxmlc/compc compiler processes in this case (see File | Settings | Compiler | Flex Compiler).

0
Comment actions Permalink

I mean in Highlighting only. Though my compiler is also set to mxlm/compc.

Here is my setup that is causing problems.

Away 4.0 Demo Module uses SDK flex_sdk_4.5.1.21328_air_3.0b2
Common Core Module uses SDK flex_sdk_4.5.1.21328_air_2.7

Away 4.0 Demo Module depends on Common Core Module

Code in Away 4.0 Demo Module

var s:Stage3D = stage.stage3Ds[0];

stage3Ds turns red with error "unresolved variable", oddly though Stage3D does code complete and works.

Compiling the module works, and the SWF runs fine. I am just losing code completion on some things.

If I remove the dependency on Common Core Module this code is not highlighted as incorrect.


I am not sure if this is part of the problem or just another problem but when I go into the Flex Compiler Settings Tab
for my Away 4.0 Demo Module then choose advanced. I am unable to change the Target Flash Player Version to 11.0.0.
When I type 11.0.0 into the boxes and hit Apply the boxes change back to 10.2.

To work around this I have downloaded the Flash Player 11 Global SWC and replaced the 10.2 SWC with it. This seems
like a really hacky work around. Could this also be causing trouble with intelliJ knowing which SWC to use for some code completion?

Is there a way I can set that to 11.0.0?


-ross

0

Please sign in to leave a comment.