Unable to use Groovy 2.4.3

Is there a maximum Groovy version that you can use in plugin development?

When including Groovy 2.4.3 in my build.gradle, Intellij gives me this error:

"groovy-all is loaded in version 2.4.3 and you are trying to load version 2.3.9"

I'm using Intellij 14.

2 comments
Comment actions Permalink

There should be neither maximum nor minumim version for any library, thanks for mechanism of plugin classloader .
But we have an issue with Groovy library, which I can reproduce after you've pointed me to Groovy & Gradle.

For further progress please follow https://youtrack.jetbrains.com/issue/IDEA-141427

0
Comment actions Permalink

Unfortunately, for now we cannot allow diferent versions of Groovy in plugins.
There are several reasons including Groovy extension modules loading mechanism and dependencies on Groovy in other plugins.
Please use bundled Groovy library.

0

Please sign in to leave a comment.