Polymer 1.0 support in IDEA

Are there plans to update Polymer and Web Components plugin with support for Polymer 1.0? Any timeframes?

Kind regards,
Boris

6 comments
Comment actions Permalink

https://youtrack.jetbrains.com/issue/WEB-16750 is fixed already, fix should be available in the most recent plugin version (141.1518)

0
Comment actions Permalink

Elena,

Thank you for a fast response and for the great news!

For some reason the most recent version of the plugin does not show up in the Preferences/Plugins dialog. I see version 141.2 instead. What should I do to make the latest version appear?

Kind regards,
Boris

0
Comment actions Permalink

It worked. Thank you, Elena!

0
Comment actions Permalink

Polymer plugin auto-completes the html tags,

but can it auto-write the link import statements (like php auto-write the use statement when you write an object) ?

That would be a huge time saver.

0
Comment actions Permalink

No:( If you miss this feature, please feel free to file a request for it to youtrack, https://youtrack.jetbrains.com/issues/WEB

0

Please sign in to leave a comment.