Code format not working in Mac OS X 14?

I've just recently started using IntelliJ from Eclipse, and I am having a very hard time getting code formatting to work as I expect.

It doesn't even seem to be respecting the formatting I set up for YAML files, which was to simply indent by 2 spaces. I've attached a screen shot showing a clearly out-of spec YAML file and the fact IntelliJ seems to think it's formatted correctly.

I've had similar problems with Java files and the layout of imports. I edited the config to add a blank line between each group and it never formats that way.

What's going on? Is this just broken?



Attachment(s):
yaml settings.png
yaml already formatted.png
3 comments
Comment actions Permalink

Do you have .editorconfig file anywhere in your project? Try disabling editorconfig support in Settings/Editor/Code Style by unchecking 'Enable Editorconfig support' checkbox - does it make any difference?

0
Comment actions Permalink

No .editorconfig files in the project.

Unchecking the checkbox does not make a difference.

0
Comment actions Permalink

It appears that formatting for YAML is not implemented yet, you can vote here: https://youtrack.jetbrains.com/issue/RUBY-2185 .

0

Please sign in to leave a comment.