No Rspec gem found in sdk through IntelliJ

I am trying to get a project to work that was created through RubyMine. I have an ultimate version of IntelliJ and would rather use that with the Ruby plugin to run these tests.
However when I attempt to run I get an error saying "No Rspec gem found in SDK". I havent


My Gem environment looks like this:

mac:~ cmietzner$ gem environment

RubyGems Environment:

- RUBYGEMS VERSION: 2.4.7
- RUBY VERSION: 2.2.1 (2015-02-26 patchlevel 85) [x86_64-darwin14]
- INSTALLATION DIRECTORY: /Users/colemietzner/.rvm/gems/ruby-2.2.1
- RUBY EXECUTABLE: /Users/colemietzner/.rvm/rubies/ruby-2.2.1/bin/ruby
- EXECUTABLE DIRECTORY: /Users/colemietzner/.rvm/gems/ruby-2.2.1/bin
- SPEC CACHE DIRECTORY: /Users/colemietzner/.gem/specs
- SYSTEM CONFIGURATION DIRECTORY: /etc
- RUBYGEMS PLATFORMS:
- ruby
- x86_64-darwin-14
- GEM PATHS:
   - /Users/colemietzner/.rvm/gems/ruby-2.2.1
   - /Users/colemietzner/.rvm/gems/ruby-2.2.1@global
- GEM CONFIGURATION:
   - :update_sources => true
   - :verbose => true
   - :backtrace => false
   - :bulk_threshold => 1000
- REMOTE SOURCES:
   - https://rubygems.org/
- SHELL PATH:
   - /Users/colemietzner/.rvm/gems/ruby-2.2.1/bin
   - /Users/colemietzner/.rvm/gems/ruby-2.2.1@global/bin
   - /Users/colemietzner/.rvm/rubies/ruby-2.2.1/bin
   - /usr/local/bin
   - /usr/bin
   - /bin
   - /usr/sbin
   - /sbin
   - /usr/local/git/bin
   - /Users/colemietzner/.rvm/bin

Screen Shot 2015-05-16 at 4.07.41 PM.png
5 comments
Comment actions Permalink

Could you please attach the list of gems for ruby-2.2.1@global? ('gem list')

0
Comment actions Permalink

I had a similar issue with Ruby 3.0 and looked at the gem environment and change the "Gem bin directory" in IntelliJ project structure SDK settings to be - GEM PATHS:
- {YOUR HOME Directory}/.rvm/gems/ruby-3.0.0
which works. Default path picked up by IntelliJ was with the bin at end {YOUR HOME Directory}/.rvm/gems/ruby-3.0.0/bin which didn't work

0
Comment actions Permalink

 

@Irfanaansari,

what IDEA and Ruby plugin versions do you use? In addition, how did you install Ruby 3.0.0?

0
Comment actions Permalink

Hi Olga, 

IntelliJ IDEA 2016.3.1
Build #IU-163.9166.20, built on December 6, 2016
JRE: 1.8.0_112-release-408-b2 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

 

Ruby Plugin version :  Version: 2016.3.20161117

and I installed Ruby 3.0 using rvm and I use Mac as development machine.

Regards,

Irfan

0
Comment actions Permalink

Hi Irfan,

in my case `rvm list known` doesn't show version 3.0.0 (rvm version is 1.27.0). What command did you run to install it?

0

Please sign in to leave a comment.