Foreign Language Keyboard Shortcuts

Answered

I am working in Seden for a short period of time and have come unstuck with keyboard shortcuts.

The most obvious one is Comment With Line Comment "Ctrl + Slash"

The slash on a Swedish keyboard is Shift-7, which prevents me from using the shortcut.

I can use the Windows language bar to switch to a UK keyboard but I don't always remember 100% where everything is.

Has anyone else come across this issue?

Is there a quick way for me to change the shortcuts and then share them with the other people in my team?

Maybe export the keymap to XML or something?

EDIT: Just noticed that I can use the NUM Slash as well for the comment, but the sharing question still stands.

17 comments
Comment actions Permalink

Hello,

Feel free to check IJ keymap concept:

... All user-defined keymaps are stored in separate configuration files under the config/keymaps subdirectory in the IntelliJ IDEA profile directory:
  • Windows and *NIX systems: <User home>/.IntelliJ IDEA<xx>/config/keymaps
  • Macintosh systems:~/Library/Preferences/.IntelliJ IDEA<xx>/keymaps/


You may submit corresponding tickets that target lack of documentation if necessary to IJ tracker as well.

Regards, Denis

-3
Comment actions Permalink

The ctrl+slash shortcut isn't working on german keyboard layout too. My workaround has always been to use the "divide by"-sign on the numpad instead of "slash". This works out of the box for me.

0
Comment actions Permalink

I have the same problem. I have us layout and german layout. Altough I have switched to us layout. the ctrl + / not working and and 'z' and 'y' are switched

 

1
Comment actions Permalink

I have the same problem on my MacBook. Fortunately it is easy to redefine shortcuts. Just go to Preferences -> Keymap and search for the command and assign it to any shortcut you like. 

0
Comment actions Permalink

I have a macbook with Turkish keyboard. When I hit CMD + ., line commenting works.

0
Comment actions Permalink

I don't think redefining all the shortcuts can be considered a solution... This is very frustrating and not happening in other IDEs (e.g. Eclipse). If this cannot be easily solved, I'll keep using Eclipse.

2
Comment actions Permalink

We have a ticket for this problem, please upvote:

https://youtrack.jetbrains.com/issue/IDEA-165950

3
Comment actions Permalink

All the users must be familiar with all the necessary suggestions or tricks that will be really very productive to make an effective grip on such platforms to save the accessing time. It will be really very beneficial for them. The users must be familiar with all these useful tricks from Epson error code 0xf1 for their own benefits.

 

-1
Comment actions Permalink

Hi there,

It looks like this problem is still not solved. I have a French layout and a UK layout in my system. When switching to UK layout, none of ctrl + A/Z works, the system still takes the French layout, e.g. for undo, I need to ctrl + w, while when I check the Settings > Keymap, it shows undo is ctrl + z. This is very confusing. Please fix it.

Best,

0
Comment actions Permalink

Hi,

Same problem with the Spanish keyboard layout. Please suggest an alternative set of shortcuts depending on the existing layout.

 

Thx!

0
Comment actions Permalink

Same problem here with a Swedish keyboard.. plz fix asap!

1
Comment actions Permalink

Same problem here, I am using two physical keyboards, one US-English, one German, for pair-programming. I have a hotkey for switching the logical keyboard layout so my pairing partner can use the German keyboard he is used to. Yet the shortcuts seem to be based on the physical key location rather than the logical layout. I.e., Ctrl-Y is delete line on the US layout, but on the German layout it's the same key that deletes a line, even though now that's logical Ctrl-Z. Very confusing.

The IDE should use the logical keyboard layout, or at least offer a switch option. Apparently is does for Mac OS ("prefer key position over keychar") but doesn't for Linux?

This should be simple and work out of the box, and not something that needs to be fixed by the user.

1
Comment actions Permalink

Seriously, is this ever going to be fixed? 9 years later, nothing has happened?

1
Comment actions Permalink

I've seen that, but there is no solution there either. This should just work. Long ago.

From my perspective, nothing has happened.

0
Comment actions Permalink

Same with Swedish keyboard. It seems to add a shortcut one the line (a 7 is popping up in the left border).

0
Comment actions Permalink

If you are on Mac try Prefer key position over key char with national layout option in Preferences | Keymap.

1

Please sign in to leave a comment.