Can not get Android emulator to run: PANIC: Missing emulator engine...

Decided to get back to android development learning. On Mac OSX.
Have the android sdk installed and can run and update the android sdk manager from command line.
(Note sure even if IDEA is using that though.)
Anyway, whenever I try to run the emulator (tried using the default Nexus one for Google AVD that was in the drop down)

I get
PANIC: Missing emulator engine program for 'arm' CPUS.

I've even tried to create a different AVD using the using the chooser in IDEA next to the "prefered android virtual device" option.

Even after I create on there and try to use it, I'll get a similar error as above ( for 'arm' of for 'x86' depending on what I chose.)

I also notice if I go back to the edit configuration screen, the AVD is in red so something isn't right but not sure what?

Thanks for any help

Screen Shot 2015-04-30 at 5.28.53 PM.png
Comment actions Permalink

Bump. Anyone with ideas?

Comment actions Permalink

Can you run emulator from AVD Manager in the SDK?

This issue may have nothing to do with IntelliJ IDEA. If reinstalling SDK from scratch doesn't help, try looking for help at .


Please sign in to leave a comment.