Gutter width/line numbers?

Answered

I upgraded from 13 to 14.1 tonight, imported my old 13 settings and while I had no problems with that effort, the gutter is bothering me a bit.  In 13.x the gutter wasn't nearly as wide and the line numbers were segregated by a dotted vertical line within the gutter.  I think the gutter is wider because of these new inferred annotation @ signs.  Is there a way to clean this back up and add the vertical dotted line back and disable those @ signs and maybe reclaim some width?

Here's an image of what I'm talking about:
gutters.png

Thanks!

5 comments
Comment actions Permalink

There is no way to disable it. In previous versions gutter could become wide too when multiple icons were stacked there.

You can submit a request at http://youtrack.jetbrains.com/issues/IDEA .

0
Comment actions Permalink

Go to View > Active Editor > Disable "Show Gutter Icon"

 

You can make this the default setting by going to Settings > Editor > General > Gutter Icon and unchecking the "Show Gutter Icon"

3
Comment actions Permalink

To make it permanent -

Right click on gutter > Configure gutter icons > Uncheck show gutter icons > Save 

1
Comment actions Permalink

Really surprised how much screen real estate the numbers column is given:

I love how netbeans deals with this while keeping a trim line numbers column:

1

Please sign in to leave a comment.