Prevent double click on tab from maximizing the editor?

Answered

Is it possible to disable having double click on an editor tab maximize the window? I never use this feature intentionally only accidentally.
I use i3wm and I float the run dialog, everytime I spuriously double click on an editor tab it messes up my entire desktop layout and it takes
sometime to fix it back up and knocks me out of my flow.

Thanks,
Ben

12 comments
Comment actions Permalink

There is no way to disable it, sorry.

You can submit a request at http://youtrack.jetbrains.com/issues/IDEA .

0
Comment actions Permalink

this double click functionality drives me crazy!

1
Comment actions Permalink

The source may be my mouse is sensitive but I am facing this issue multiple time per day. I never double-click on a tab to maximize the IDE. I would like to disable this because it is more often messing my layout and interrupting my work.

If someone have a solution, please share.

Thank you!

0
Comment actions Permalink

@Sebastien DErrico

Sounds like your workflow is to click the tabs to switch editors? If so, consider using the keyboard shortcuts instead. It's faster and more convenient, and neatly resolves the tab double-click issue as well.

If you double-click the tab again after the first double-click, does it restore the layout? If not, have you tried `Window > Store Current Layout as Default` and then `Window > Restore Current Layout (Shift+F12)` to restore things after a tab double-click?

0
Comment actions Permalink

Please see https://youtrack.jetbrains.com/issue/IDEA-138797.

Starting from IntelliJ IDEA 2019.1 you'll be able to disable this behavior by adding -Deditor.maximize.on.double.click=false in Help | Edit Custom VM Options.

3
Comment actions Permalink

@Roger I am on 2018.02 on Mac. `Window > Store Current Layout as Default` does not work in this case.

0
Comment actions Permalink

@Maciej

Odd...

I get the feeling the tab double-click feature is kind of bolted on, since it doesn't have the usual configuration options. Maybe that's why the the layout is not always properly restored as well.

Double-clicking the tab again does work in restoring the layout for me (Linux, and 2018.2.4).

In any case, seems like a solution is forthcoming :)

0
Comment actions Permalink

ohhhh.... so It's working when I double click again on tab with file name. I was clicking on Project tab ;)

Anyway I would expect the same behaviour in both cases.

0
Comment actions Permalink

@Maciej

Maybe everyone that posted here are in the same boat?

So your Project tab is still visible after maximizing the editor? When I maximize the editor, only the editor tabs remain visible.

 

 

0
Comment actions Permalink

yes - it's visible:

0
Comment actions Permalink

Oh, those! I have them hidden since I rarely use the mouse for navigation.

Thank you for clearing up the mystery :)

0
Comment actions Permalink

Serge Baranov  you are amazing! thank you a thousand times! You make my life worthwhile again.

0

Please sign in to leave a comment.