Cannot create play 2 project

Hi

I just downloaded IntelliJ  14.0.3 build 139.1117 and would like to use Scala related features.  I can create Scala and SBT project without any problem. But when I tried to "Play 2.x" project, ti always pop up "sbt project name must be a valid scala identifier" even if  the project name is perfectly valid. (please see the screenshot)

This issue happened on both Mac and Windows platform.  Any suggestions?

thanks

Frank



Attachment(s):
Untitled1.tiff
2 comments
Comment actions Permalink

Hi Frank, I ran into the same issue as well.  Unfortunately, the official method does not seem to currently work.  There's a bit of history in the comments at https://confluence.jetbrains.com/display/IntelliJIDEA/Play+Framework+2.0

In short, the suggested method is here:  https://confluence.jetbrains.com/display/IntelliJIDEA/Play+Framework+2.0?focusedCommentId=57287323#comment-57287323

Written out:

If the Scala plugin is enabled in IntelliJ IDEA, you can select New Project -> Java and in the right part of the page, from the "Additional Libraries and Frameworks" list, select Play 2.x  to create Java project with Play 2.x framework.

New documentation is supposed to be up at https://www.jetbrains.com/idea/help/play-framework-2-x.html?search=play but still does not work if you select Java -> Play 2.x and leave Scala unselected.  Both must be selected for it to actually generate a Play 2.x project.

Hope this helps.

0
Comment actions Permalink

 

"sbt project name must be a valid scala identifier"

Can also mean that you should not use white spaces in your project name. Removing them fixed it for me ...

0

Please sign in to leave a comment.