9.0 Beta build hangs on MacOS

Hi...
I have been using the beta release of 9.0 with a number of flex modules (10-15).  It runs any where from 5-15min and then completely hangs and has to be killed.  I did see the other thread on Mac issues, but this seemed a little different as there is 0-1% cpu usage, it is just waiting as the dump suggests.  I have tried it w/ both Perforce enabled/disabled.  I attached a thread dump.

I am using:
10.6.2
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)

I have been using options of:  -Xmx  -Xms32m -Xmx756m -XX:MaxPermSize=256m -server -ea -Xbootclasspath/a:../lib/boot.jar

thanks.
-B



Attachment(s):
idea9Hang.rtf
4 comments
Comment actions Permalink

Fixed in IDEA 9 post beta EAP (92.24)

Brandon Lonac wrote:

Hi...
I have been using the beta release of 9.0 with a number of flex modules (10-15).  It runs any where from 5-15min and then completely hangs and has to be killed.  I did see the other thread on Mac issues, but this seemed a little different as there is 0-1% cpu usage, it is just waiting as the dump suggests.  I have tried it w/ both Perforce enabled/disabled.  I attached a thread dump.

I am using:
10.6.2
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)

I have been using options of:  -Xmx  -Xms32m -Xmx756m -XX:MaxPermSize=256m -server -ea -Xbootclasspath/a:../lib/boot.jar

thanks.
-B

---
Original message URL: http://www.jetbrains.net/devnet/message/5250899#5250899



--
Best regards,
   Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Or you can download updated beta release 9#193

Brandon Lonac wrote:

Hi...
I have been using the beta release of 9.0 with a number of flex modules (10-15).  It runs any where from 5-15min and then completely hangs and has to be killed.  I did see the other thread on Mac issues, but this seemed a little different as there is 0-1% cpu usage, it is just waiting as the dump suggests.  I have tried it w/ both Perforce enabled/disabled.  I attached a thread dump.

I am using:
10.6.2
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03-219)
Java HotSpot(TM) 64-Bit Server VM (build 14.1-b02-90, mixed mode)

I have been using options of:  -Xmx  -Xms32m -Xmx756m -XX:MaxPermSize=256m -server -ea -Xbootclasspath/a:../lib/boot.jar

thanks.
-B

---
Original message URL: http://www.jetbrains.net/devnet/message/5250899#5250899



--
Best regards,
   Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Awesome, that did the trick.  Back in business.  Thank you.

0
Comment actions Permalink

Hello,
I'm having the same problem with Idea 9.0 build#IU-93.13, under Windows Seven and Vista. Idea freezes after a few minutes, even if I'm simply editing an mxml file, not only during a build. No activity is signalled, and no error occurs...

0

Please sign in to leave a comment.