Problems with file encoding moving to Win7

I recently moved from legacy XP machines at my employer where I used IntelliJ 14 and moved onto "new" Win 7 boxes.I copied the files directly from the old box and restarted the Ide and all seemed to work with a few teething problems with a new version of svn, etc.I seem to be having some problems with encoding in the new Win7 O/S.I have maintained the old x86 Java 1.6 to make sure it's not an incompatibility, but I have the File/IDE encoding set to System Default in Settings.If I hit the Cntrl-Space button the encoding changes and I start getting weird characters which look Japanese or other. The only way I can resolve this is to restart the GUI. If I don't use the Cntrl-Space it seems to behave correctly, but this is an intrinsic part of using Intellij and it was no problems on the old XP box.Anyone have any clues or fixes for this? I've tried various Encodings such as UTF-8, UTF-16, Windows-1252, etc without success.Cheers,
2 comments
Comment actions Permalink
I did some googling and it appears in Win7 by default cntrl-space puts you into Chinese character set, however using the Control Panel it continually gets reset.I found an article where the permanent fix is to edit registry entries and reset but I haven't done it on my work machine as it's against company policy to mess around with those things.http://superuser.com/questions/327479/ctrl-space-always-toggles-chinese-ime-windows-7
0

Please sign in to leave a comment.