Groovy configuration with version 9

Hello all,

I have been an IntelliJ user for many years, but I am stuck on Groovy in version 9.

When I try to run Groovy code I get the message "Groovy is not configured", and it pops up the module settings.

However, I can't find a Groovy or a Groovy Configuration anywhere in any setting.

Groovy works if I add a Library with the Groovy JARs to the module.  But is that "configuring Groovy"?

Is there a better / more correct way to "configure Groovy"?

Thanks
Peter

3 comments
Comment actions Permalink

I would say: add the Groovy facet to the project.....but then I looked, and it was nowhere to be found. I thought I didn't has the JetGroovy plugin installed, but it is...so, in short: I have no idea, and would also like to know, to be honest.

0
Comment actions Permalink

You can take a look at the Groovy-related Configuration Changes blog posting. If I understand it correctly, all you need to do to "configure" a groovy project is place a Groovy jar on your class path:

Also, you can now write Groovy code and get full coding assistance with compilation as long as you have Groovy jars anywhere in a module classpath. Together with the new compiler Resource patterns path constraints feature (/ - path separator; /**/ - any number of directories) this made Groovy facet obsolete. So, there is no Groovy facet anymore.


To easily add the groovy jars (for non maven projects), you can right click your module name in the Project tool window, select "Add Framework Support...", and  select Groovy in  the dialog. In the Groovy Settings text filed that appears, enter the path to your Groovy SDK.

0
Comment actions Permalink

Great! Thanks Mark,

So here's a feature request to help future users-- instead of popping up the module dialog box, pop up the "add framework" dialog.

Thanks
P

0

Please sign in to leave a comment.