Valid Ruby hash showing error. How do I properly set the Ruby SDK to 1.9?

IDEA version: 13.1.5
Ruby Plugin Version: 6.5.2

New Ruby hashes are shown as having errors.

Error I'm seeing:
errors.png
Settings:
psdk.png

msdk.png

sdk.png

2 comments
Comment actions Permalink

I got it working by removed the .idea folder and recreating the project. A .iml file was created with the line

<module type="RUBY_MODULE" version="4">

which i assume resolved the issue. Not sure why this file did not exist before.

0
Comment actions Permalink

Follow-up: If I am editing a ruby file in a Node.js application project.  I am running into the same problem as the original author describes.  Is there a way to help intellij interpret the ruby file with a more modern opinion?

Cheers

0

Please sign in to leave a comment.