Open Project Dialog

I've got the Reopen Recent Project command mapped to a keystroke. When the dialog opens, the focused button used to be "This Window", which I got used to. Then you changed the default focus to the "New Window" button, which I got used to. Now you've gone and added the "Remember, don't ask again" checkbox and now THAT control has the focus. Will you guys make up your minds already? Please change the focus back to "New Window".

6 comments
Comment actions Permalink

What is your OS, IDEA, Java version? Please attach idea.log https://intellij-support.jetbrains.com/entries/23352446 and screenshot of the dialog. It is always focused on "This Window" control for me.

0
Comment actions Permalink

OS X 10.10.1
Idea 14.0.3 (prior verisons didn't have the checkbox)

Screen Shot 2015-01-29 at 5.26.37 PM.png



Attachment(s):
idea.log.zip
0
Comment actions Permalink

You should be able to apply "This Window" option with the Enter key.

Idea 14.0.3 (prior verisons didn't have the checkbox)

Remember, don't ask again checkbox has always been there. Which version do you mean specifically?

0
Comment actions Permalink

Yes, I can apply "This Window" with the enter key, but the point I'm trying to make is that the focused control has changed several times in the last few releases. In 14.0.2, the checkbox did not exist and the focus was on the "New Window" button allowing me to hit spacebar to select that button as you can see in the attached screenshot.
Screenshot 2015-01-29 20.00.15.png

In the version prior to 14.0.2, I think the order of the buttons was different so I had to hit tab to get the "New Window" button.

Andrey, thank you for your replies, and I apologize for getting "testy" in my initial post, but I live in this product and I frequently use this dialog to switch between projects, so it's been very frustrating to have to relearn new keystrokes with every release.

0
Comment actions Permalink

In 14.0.2, the checkbox did not exist and the focus was on the "New Window" button allowing me to hit spacebar to select that button as you can see in the attached screenshot.

This option was added for native mac dialogs recently. And looks like we have issue addressing the problem you are describing https://youtrack.jetbrains.com/issue/IDEA-123409 .

Also to always have the same behavior you can disabled mac native dialogs by disabling Registry key `ide.mac.messages.dialogs.as.sheets` http://stackoverflow.com/a/11829639

0
Comment actions Permalink

Ah ha! After disabling native Mac dialogs, I believe the Open Project dialog returned to what it was prior to 14.0.2:

Screen Shot 2015-01-30 at 7.52.25 AM.png

So now in this thread you can see all the changes this dialog has gone through simply by updating IntelliJ itself, and why it has been so frustrating.

Thanks for the tip on disabling the native dialogs in the registry. This unfortunately changes the default focus back to "This Window" again, but at least it will hopefully remain that way for good.

0

Please sign in to leave a comment.