"Error: ZIP file must have at least one entry" with 92.24?

I installed the latest version IU-92.24 today but when I try to build my web application, I get this error... Not sure why, using IU-90.193 works with no error...
Also I have no zip files in my project but I guess it might be a jar files it complains about... Any new check that could be a reason for this?

How can I fix it?


Regards,

BTJ

7 comments
Comment actions Permalink

Hmm... Did an invalidation of the cache and restarted IDEA and then it didn't complain anymore.... :-|

BTJ

0
Comment actions Permalink

rebuild project did it for me

0
Comment actions Permalink

Tried that, twice... But had to invalidate the cache...


BTJ

0
Comment actions Permalink

The problem will be fixed in next EAP build. However it seems that you don't need to invalidate caches to workaround it. Just build your app again.

Tried that, twice... But had to invalidate the cache...


BTJ

---
Original message URL: http://www.jetbrains.net/devnet/message/5250326#5250326



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Not true.... I am getting this error every time I change my dependencies in my pom files and rebuild does not help; I have to invalidate the cache!


BTJ

0
Comment actions Permalink

Same here.

Tried rebuilding to no avail, "invalidate caches" did fix it however.

0
Comment actions Permalink

Got the same Problem. Im building my application in parts with maven and whenever I do an "import Maven Changes" this error occurs.

Occasionally I got the same error in the previous build but a second build of the project would fix it, which isnt the case any more.

Is there any timeplan when this bug is fixed / a new eap version is released, this is a real showstopper...?

0

Please sign in to leave a comment.