CTL-ALT Keyboard Shortcuts IU-90.94 OS-X 10.6

I am running IDEA Ultimate with the standard keyboard layout on OS-X 10.6 and lost many CTL-ALT keyboard shortcuts (CTL-ALT-B, CTL-ALT-T). Is this a known problem?

Thanks and Regards,
Peter

4 comments
Comment actions Permalink

This is really driving me nuts. It happens on all my Snow Leopard 10.6.1 systems - using IDEA Ultimate up to IU-90.122. For a test - when I try to assign a keyboard shortcut for "Surround with" using the standardd CLT-ALT-T shortcut, I do not get anything in the dialog. I also tried this in FlexBuilder/Eclipse just to make sure the shortcut is not intercepted by some other application or the Finder but it works fine there. So I conclude that it has to do with IntelliJ. Can someone please confirm that it works/does not work on Snow Leopard (please try CTL-ALT-B, CTL-ALT-T, CTL-ALT-I which I use a million times a day)?

Thanks and Regards,
Peter

0
Comment actions Permalink

Fixed in IU-90.162 - thanks!

Peter

0
Comment actions Permalink

Oh no - it's not fixed

Some CTL-ALT keyboard shortcuts (e.g. CTL-ALT-I, CTL-ALT-T, CTL-ALT-B, CTL-ALT-F7) do not work on a _German_ keyboard under OS-X 10.6.1. I had switched to a US keyboard and thought the problem was fixed.

Please fix for IDEA Ultimate 9 final.

Thanks and Regards,
Peter

0
Comment actions Permalink

Never mind. I changed the keyboard map to OS-X getting used to the CMD key - now I have even more options for shorcuts. I thought my CTL brain should be compatible with the Windows/Linux fellow programmers, but what the heck - I'll never use Windows anyway. THEY should get a Mac

Peter

0

Please sign in to leave a comment.