command line: unknown configuration variable 'swf-version'

Setting up IDE for FLEx Project. Created simple project and used FLEx SDK 4.5. Compiling produces below error. When i use SDK 4.6 then no issues. I have tried both mxmlc and compiler shell.

command line: unknown configuration variable 'swf-version'

6 comments
Comment actions Permalink

Works fine for me with any version of Flex SDK. What IntelliJ IDEA version do you use?
And do you need to use those ancient SDK releases? Apache Flex SDK has reached version 4.13 already.

0
Comment actions Permalink

IntellijIDE 14 ultimate

4.5 is what we use..too many flex apps...plan is there for upgrade but not until 6 months.

0
Comment actions Permalink

I tried with the Flex SDK 4.5.0.20967 and it supports'swf-version' without problems. Are you using standart Adobe Flex SDK with standard bundled AIR SDK 2.6.0.19120? What exact versions (see Dependencies tab of your Flash build configuration)?

0
Comment actions Permalink

flex_sdk_4.5.0.17689

aircore.swc
airframework.swc
airglobal.swc
airspark.swc
applicationupdater.swc
applicationupdater_ui.swc
datavisualization.swc
flash-integration.swc
flex.swc
framework.swc
mobile.swc
mobilecomponents.swc
mx.swc
osmf.swc
playerglobal.swc
rpc.swc
servicemonitor.swc
spark.swc
spark_dmv.swc
sparkskins.swc
textLayout.swc
utilities.swc

0
Comment actions Permalink

This looks like one of the pre-release beta versions. We are not going to support outdated beta SDK as the official 4.5.0 release was published 4 years ago. I'm not sure if official 4.5.0 is available in the internet, so old it is.

0
Comment actions Permalink

Thanks for your input.

4.5.0.2 worked as expected. We are good for now.

0

Please sign in to leave a comment.