Disable rich-text copying?


Is it possible to simply disable rich text copying in IDEA 14? I sometimes copy from IDEA and paste into Evernote, and as if IDEA 14, the pasted text often ends up huge and green. It takes extra steps to get rid of that unwelcome formatting, or you can use paste plain, which can lead to other problems.

I know you can create a color scheme just for this, but I'd rather not go through all that, and keep it updated, if there's a simpler way, which there really should be.

Thanks for any thoughts.

Comment actions Permalink

No other thoughts? This new feature gets in my way pretty much every day, when I paste text into a rich-text email and it's huge, and in a different font and color.

The ability to setup special settings for this is great, if you need it, but a simple checkbox or dropdown selection for plain text would really make a lot of sense.

Comment actions Permalink

Invoke Help->Action, type "Registry" and disable "editor.richcopy.enable"

Comment actions Permalink

Thank you, great answer! I'm always amazed at everyting IDEA has in it, very mature product with a ton of features and control, love it.

This isn't as good a solution as if one of the options in the Rich-text copy dropdown was 'Disable', and I see you've already filed an issue for that, great.

I've never heard of this Registry dialog, and can't find any references to it in the help. I also don't quite understand it.

  • Should we consider this a workaround/hack, or an interface to settings people don't typically need to touch?
  • Is anything in there so dangerous we shouldn't change it?
  • Does IDEA actually honor all these settings?
  • What are the checkmarks in the lefthand column?
  • What does the Edit button do? Nothing, as far as I can tell.
  • What's the difference between the smaller '-' (Revert) button at the top and the big Restore Defaults button at the bottom?
    • Does the top one apply only to highlighted items?
    • Does the 'Delete' indication in its tooltip mean it actually removes items from this dialog, or just reverts their settings to the factory default?
  • Just out of curiousity, what is wolf.the.problem.solver?
  • FYI, the description for localHistory.daysToKeep is messed up.

Anyway, thank you again for this specific solution, it's just what I needed.

Comment actions Permalink

About registry dialog: Short answer - don't touch it unless instructed by an authorized person.

Long answer: Here you can configure some [hidden/experimental/not ready for production/known problem workaround] options throughout IntelliJ's features.

Check mark in the leftmost column indicates setting which requires a restart to take effect.

Oh, and really, do not change anything unless you know what it does.

Comment actions Permalink

Thanks for the info, appreciate it.

I already changed a few things whose meanings seemed clear:

  • tabs.alphabetical
  • localHistory.daysToKeep
  • keymap.show.alias.actions (not completely clear on this, thought I'd check it out)

Should I put those back? If so, please tell me about the two different Revert buttons.

Thanks again.

Comment actions Permalink

tabs.alphabetical: affects editor tabs ordering
localHistory.daysToKeep: determines number of days for which local history will keep backups (depends on your usage if and how long you need it)
keymap.show.alias.actions: shows alias actions (?) in Keymap configuration editor

"Restore Defaults" will reset _all_ configuration keys, whereas the "-" button on top of table will only revert currently selected entry.

Comment actions Permalink

Thanks, that's all about what I figured, and it seems you're not any clearer than me on what"alias actions" are.

You also didn't tell me to revert any of those immediately, so I won't :)

Thanks again for all your help, very much appreciated. I think I like tabs in alpha order maybe, and disabling rich text copying is a huge hassle-saver.

Comment actions Permalink

Excuse me for necroposting, but the solution by Yann Cebron is no longer valid. In IDEA 2017.2.3 there is no registry key "editor.richcopy.enable" anymore :(

Is there any other solution besides obvious workarounds like pasting in notepad and copying again?

Comment actions Permalink

It looks like there is a setting to enable or disable rich text copying behavior. See this help article.

Comment actions Permalink

Now, v2018.2, it's available from the setting menu. Editor->General->Rich-text_copy

Comment actions Permalink

I think that a better solution it's define a shotcut for copy plain text. You can define it on Settings -> Keymap -> "Copy as Plain Text"

Is very handy the shortcut "Ctrl + Shift + C" because several text editors use the same one for that function


Please sign in to leave a comment.