Intellij 14: How to turn off auto indent on enter

Answered

Just bought the new Intellij14 and now I have to discover that each time I hit enter typing in some control structure code (like switch-case) it automatically tries to put it on the the "right place" but its not.

E.g. After hitting enter after each case ... : it puts it one more step in, but I want it in one line.

 
case UC6CD:
    case UC7:
        case UC7CD:
            case UC7D:
                case UC7N:



This is really bugging me. Either fix it or does anyone know how to turn this off.


This was never an issue till this version !!!!

Cheers, Rob.

6 comments
Comment actions Permalink

To turn off indentation on enter please uncheck "Smart ident" in "Editor | General | Smart Keys" https://www.jetbrains.com/help/idea/smart-keys.html

3
Comment actions Permalink

How do I DISABLE auto indentation? @Intellij team respond!!!!!!!

2
Comment actions Permalink

If only this was the only thing these ***SMART*** IDEs got wrong.

Why is there no "plain editor mode"? You could even call it "sane editor mode" and turn it on by default.

1
Comment actions Permalink

Thanks for the help. Worked well.

1
Comment actions Permalink

Thank you so much, it works well now 

1
Comment actions Permalink

This has to be one of the most frustrating IDEs. After years of Jdeveloper, Eclipse, etc., I thought this would be a welcome change. The worst 4 hours with an IDE ever.

-1

Please sign in to leave a comment.