Need help -- "Perforce is unavailable." when editing file with IntelliJ 9.0.1

I hope someone can help me with this. It is likely just a simple user configuration problem.

My perforce server is running on Windows 7. It works and functions as intended.

I was able to successfully connect to the perforce server using IntelliJ 9.0.1 settings (The "test connection" button returns success, when I use my p4 username "tigris", doesn't connect when I change it to any other username -- which is expected behavior. So the connection works.)

Now everything works. Except one thing. When I start to type into the file from IntelliJ, the normal "Clear Read-only" Status window pops up asking to make a choice between:

    1. Using file system
    2. Using version control integration  (this is of course the one I need)

However, when I choose 2., I get a second popup:

"Perforce is unavailable. Do you want to clear read-only file attribute using file system?"

No, I don't. I want it to be sent into perforce default change list, of course.

Can Anyone help? Below is the screenshot of what this looks like:


1 comment
Comment actions Permalink

I was able to fix it.

I needed to go into IntelliJ perforce settings and use my workspace name, not my user name. Interestingly, both "tigris" (which is my user's name) and "tigris_wspace_75" worked (test connection returned success on both). However, only when I used tigris_wspace_75, which is the actual folder/workspace/depot name... then it started to work. The message disappeared and I can now automatically check out the pages by starting to edit them.

Just putting it out there for future reference in case someone is experiencing the same problem. If your perforce is misconfigured, the best thing is to reinstall perforce (delete previous installation first), then create the user with the wizard, and specify Client name as your workspace name (not your perforce user name).

Notice where the red circle  is. That's where "tigris" my username worked to pass the test -- but it did not work for checking out. Replace that with your workspace name instead. Also make sure the paths to p4.exe and p4v.exe are correct -- these executables are included in perforce installation by default.




Please sign in to leave a comment.