Go to Class/File shortcuts don't work when no editor/toolwindow is open

I remember having seen somebody complaining about it, but haven't found the issue in YouTrack:

In Maia keyboard shortcuts (ctrl-(shift)-n, ctrl-shift-f, ctrl-e...) don't work when neither an editor nor any toolwindow is open.
They simply are ignored.

I get annoyed by this many times each day.
Usually when I start to work on the next bug fix/feature I hold down ctrl-f4 until all editor windows are closed.
Also I usually have no toolwindows open at all.
Next I want to open the class I intend to start working on, but immediately get irritated, because ctrl-n does nothing.
A moment's hesitation, then I sigh and grab the mouse.

Could you please fix this regression soon? Thanks!

6 comments
Comment actions Permalink

I wonder if you are experiencing it on linux (and could be due to focus lost issues). I, however, can't reproduce it on windows.

0
Comment actions Permalink

No, Windows Vista 64 bit with latest 32bit 1.6 JDK.
Can you reproduce it this way?

Open a couple of editor tabs.
Close all toolwindows (project, debug, todo, ...).
Bring focus to the editor.
Press and hold ctrl-f4 to close all editor windows.
Try ctrl-n

Andrew Perepelytsya wrote:

I wonder if you are experiencing it on linux (and could be due to focus lost issues). I, however, can't reproduce it on windows.

---
Original message URL: http://www.jetbrains.net/devnet/message/5247530#5247530

0
Comment actions Permalink

Stephen,

I cannot reproduce the problem following your steps.  I am using IU 90.94 on Ubuntu 09.04 64-bit with java6u18ea.

Make sure you aren't getting exceptions (Check red circle or terminal where you launch IDEA). You could be having other problems, and open file/class shortcut problem could just be a symptom.

-Alex

0
Comment actions Permalink

I can't reproduce it either. I'm also on Vista 64bit with 32bit 1.6 JDK.

On 10/21/2009 2:41 AM, Stephen Friedrich wrote:

No, Windows Vista 64 bit with latest 32bit 1.6 JDK.
Can you reproduce it this way?

>

Open a couple of editor tabs.
Close all toolwindows (project, debug, todo, ...).
Bring focus to the editor.
Press and hold ctrl-f4 to close all editor windows.
Try ctrl-n

>

Andrew Perepelytsya wrote:

>> I wonder if you are experiencing it on linux (and could be due to
>> focus lost issues). I, however, can't reproduce it on windows.
>>
>> ---
>> Original message URL:
>> http://www.jetbrains.net/devnet/message/5247530#5247530

--
Martin Fuhrer
Fuhrer Engineering AG
http://www.fuhrer.com

0
Comment actions Permalink

Hello Stephen,

I remember having seen somebody complaining about it, but haven't
found the issue in YouTrack:


It's http://youtrack.jetbrains.net/issue/IDEA-24087

Thank you for details, I will try to do something similar to reproduce. At
the moment I have not yet reproduced the problem.

Alexander.


0
Comment actions Permalink

Oops, I really forgot that I commented on that already.
I have tried to reproduce the issue on a new project, and had some "success" with that, but haven't found a reliable way to make the bug happen..

0

Please sign in to leave a comment.