IDEA-9 (Maia # 10781) - more usability feedback

As I've stated earlier, build # 10781 looks quite stable and is quite usable, however the issue with "error # 24 - too many open files" is now becoming a nuisance. I've had to shut down IDEA each time I hit that error. I'm not opening more than 10 files at a time (my tab limit is set to 10 in my configuration preferences).


As well, I'm experiencing the following problems:

  • It takes way too long to shut down when Tomcat is also running inside of IDEA (I know that Tomcat runs in a separate JVM). I usually end up running kill -9 <pid> for both the IDEA JVM and the Tomcat JVM.
  • Even regular shutdowns take way too long especially with the too many open files error (not sure if IDEA is doing some housekeeping)


My environment

  • Ubuntu Linux 9.04 - dual core with 2G
  • IDEA-9 (build # 10781)


My idea.vmoptions

-Xms256m

-Xmx1024m

-XX:MaxPermSize=384m

-ea

4 comments
Comment actions Permalink

Adding screenshot illustrating the "too-many-open-files error".



Attachment(s):
tooManyOpenFiles.png
0
Comment actions Permalink

Hi,

I am running Ubuntu 9.04 also, but on a quad core workstation.   I have never seen the problems you are mentioning, but then I am not using IDEA's tomcat integration. (We use ant scripts to deploy applications) The application server I use is on anther quad core server, so the only thing I have running on my workstation is IntelliJ, Perforce, Firefox and terminals.  IDEA shutsdown in less than 2 seconds.

If you are running an appserver on the same machine as intellij, is it possible you just ran out of file handles?  Maybe you should try increasing the number of files. By default, the limit is 1024 (ulimit -n to check) which is kind of low if you are running server applications.

You can try setting "ulimit -n 5000" before launching IDEA to see if it helps.

You can edit  /etc/security/limits.conf and put new permanent defaults

*               hard nofile     5000
*               soft nofile     5000

-Alex

0
Comment actions Permalink

Alex - thanks for your suggestions. I'm definitely going to try them out. For the time being (since I am working on a time-bound project), I have reverted to 8.1.3 which is absolutely solid.

0
Comment actions Permalink

Alex - thank you very much for your suggestion. It worked beautifully. I'm once again "developing with pleasure" . I did have to reboot the system for the settings to take effect. I've been using IDEA-9 (build # 10781) all day today with Tomcat 6 running from within IDEA and my web service application being deployed and redeployed with no errors.  I seriously appreciate you taking the time to respond to my question with an excellent suggestion.

0

Please sign in to leave a comment.