Build 10781 distributed with YourKit configuration in idea.vmoptions?

Well, at least the Unix achive is. Is this intentional?

14 comments
Comment actions Permalink

Hello Samuel,

Well, at least the Unix achive is. Is this intentional?


Why do you find it strange? 10781 is an EAP build, and EAP builds usually
do have YourKit enabled.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Well I have installed many EAP builds previously and I don't recall that being there before, it also causes startup failures seeing how I do not have YourKit.
Unfortunately I'm one of those people that prefers JProfiler

0
Comment actions Permalink

IntelliJ IDEA (at least the EAP builds) comes bundled with the YourKit
agent library.

What kind of startup failure are you seeing?

-tt

0
Comment actions Permalink

IDEA EAP builds have been bundling yourkit agent for years. And one doesn't have to have yourkit for that (what you purchase is the UI part which can work with the data collected by a free agent). The only reason it could fail is if your OS wasn't supported by yourkit and there were no binaries provided for it.

0
Comment actions Permalink

Hmm, I'm using Ubuntu 9.0.4 (64) and I have builds 10597 and 10633 sitting on my harddrive.
I may have just blindly replaced the the default idea.vmoptions on those builds with the custom one I was using for Diana before starting them so never encountered the problem with those two.
I was trying to download those builds once again just to verify but http://download.jetbrains.com/idea/idea10597.zip and http://download.jetbrains.com/idea/idea10633.zip no longer exist.

0
Comment actions Permalink

I had the same problem running Maia EAP 10781 under Ubuntu 9.04, but I didn't bother posting..

/software/idea/bin$ ./idea.sh
Error occurred during initialization of VM
Could not find agent library on the library path or in the local directory: yjpagent


Here is contents of idea.vmoptions after install:

-Xms32m
-Xmx256m
-XX:MaxPermSize=150m
-ea
-agentlib:yjpagent=disablej2ee,disablecounts,disablealloc,sessionname=IntelliJIdea90


I have different idea.vmoptions I use, so I didn't really follow up on what the problem was, but it would be nice if jetbrains fixed the problem so that new users aren't frustrated..
I guess the idea.vmoptions could be correct, but the path variables aren't setup correctly to find the yourkit agent library?

-Alex

0
Comment actions Permalink

I've got same issue/error,
(both ubuntu 9.04/9.10beta)

0
Comment actions Permalink

Are you running the default OpenJDK that comes with Ubuntu or have you installed SUN's JDK?

BTJ

0
Comment actions Permalink

I am running sun JDK (jdk1.6.0_14 version)

0
Comment actions Permalink

I was using Sun's 6u16, but now am using Sun's 6u18 EAP version (http://download.java.net/jdk6/6u18/promoted/b02/binaries/)

0
Comment actions Permalink

Oki, my theory failed... :-|

BTJ

0
Comment actions Permalink

The bundled yourkit agent is a 32-bit library and will work only when you run the EAP with 32-bit JDK. If you are using x64 JDK then the only option is to remote yourkit-related line from vmoptions.

0
Comment actions Permalink

On Thu, 08 Oct 2009 13:40:40 +0000, Oleg Estekhin wrote:

The bundled yourkit agent is a 32-bit library and will work only when
you run the EAP with 32-bit JDK. If you are using x64 JDK then the only
option is to remote yourkit-related line from vmoptions.


You can download YourKit (which doesn't require registration or payment
to do) and extract the 64-bit lib from the archive.

--
Mark Scott
mark@codebrewer.com

0

Please sign in to leave a comment.