Reindexing may not be honoring exclusion list

I'm developing an application with ember-cli and find that the project reindexes every time that ember server rebuilds the project (after every file change).  The relevant directories have been excluded and I've ensured that they are not listed as libraries.  How might I stop this, and/or, what might I be doing wrong?

Thanks!

5 comments
Comment actions Permalink

Hi, again.

I moved the project over to Angular, and while the re-indexing is no longer much of a problem, the same issue exists.

Code completion/suggestions is extremely slow.  JS libraries from other projects are included regardless of my settings in the project libraries setup.  I'm not sure how to limit the referenced libraries to the project directory.  What's worse, depending on what I type, the IDE locks-up for 20 or so seconds.  The lock-ups, in particular, seemed to become worse in v14.

Please help.

0
Comment actions Permalink

I found this: https://www.jetbrains.com/idea/help/configuring-javascript-libraries.html#usage_scope

The above does not help as I do not have a "usage scope" dialog related to js.
I have been able to make minor progress so that suggestions come up after about 30 seconds when typing in something like "angular." by using "manage scopes" and assigning one to my project directory.  However, there are still an excessive amount of available libraries.

Again, please help me refine the libraries that my projects are referencing.

0
Comment actions Permalink

Message removed.

Message was edited by: CodingMusica

0
Comment actions Permalink

Message removed.

Message was edited by: CodingMusica

0
Comment actions Permalink

I figured out how to resolve this issue.  Since I was using Golang as the project SDK,  IDEA was searching every "src" directory in my GOPATH and picking up  each JS file it could find (there are many).  I excluded my project's JS directories from the Go  Module and added them back in to the project as Static Web Modules.  Now the completion pop-up shows quickly and with relevant options.

As an aside, I was able to receive direct support by creating a request here: https://intellij-support.jetbrains.com/home
I had resolved this issue myself before hearing back, but it is nice to know that Jetbrains Support is active despite a lack of response on this forum.

0

Please sign in to leave a comment.