Import Database Schema - hangs with large database

I have an oracle database with a dozen schemas and hundreds of tables each, over 10K tables total(Oracle Forms Application). After pulling in Schema, the dialog is not responsive attempting to check/uncheck tables. Hibernate allows for configuration ( includes and excludes ) as a means to filter these. Can you point me to the correct config file, or is the current dialog/filter not applying these options? I have this configuration option in my project's config.groovy and it works if executed from command-line.

Please disregard the grails component, as I found that GORM support is on the list for future consideration.

grails config:
grails.plugin.reveng.includeTables=...

2 comments
Comment actions Permalink

duane5000 wrote:

Hibernate allows for configuration ( includes and excludes ) as a means to filter these. Can you point me to the correct config file, or is the current dialog/filter not applying these options?

If I am understanding you correctly, you want to limit what tables the database plug-in checks. When you create a database source configuration, after entering the connection information on the 'Database' tab (and testing your connection), but prior to closing the dialog or clicking Apply, go to the 'Schemas & Tables' tab. On that table you can select which schema(s) to include. Then at the bottom, there is a "Table name Pattern" field. In that field you can enter a regex to indicate what table you want to include. Click the help link for more information.


ss.png

0
Comment actions Permalink

Hi, I have the same problem in Intellij2016.

The trick of using "Table name pattern" inside "Data source and Drivers" dialog used to work fine in Intellij 14, but after upgrading to Intellij2016, filters don't apply to the "Import Database Schema" dialog anymore. This is really annoying when dealing with huge databases. Besides I noticed another strange behavior with columns type mapping after upgrading: with my Oracle database, varchar2 columns are mapped by default into java.lang.Object fields and I have to manually change each field one by one to java.lang.String. Is it possible to change this default behavior?

Thanks in advance

0

Please sign in to leave a comment.