No instant completion

I've started using IntelliJ 13.1 Ultimate edition, on Windows 7, and I cannot see any instant completion for my Java code. In order to get any suggestion, I have to use Ctrl+Space.
How can I fix this?
I also don't get any suggestion about how to fix compilation problems (which I get if I use Eclipse); is this something that is supposed to work in Eclipse?
These problems, and the fact that IntelliJ doesn't compile the code while I write it, as Eclipse does, are making me consider going back to Eclipse... My productivity at the moment has definitely gone down.

2 comments
Comment actions Permalink

Autocompletion is on by default, unless you have power saving mode activated (File > Power Save Mode). For automake got ot File > Settings > Compiler > Make project automatically: check. You can switch to Eclipse compiler if you like: File > Settings > Compiler > Java Compiler > User compiler: Eclipse.

0
Comment actions Permalink

Thank you, that worked!


0

Please sign in to leave a comment.