Adding Enterprise Plugin Repository fails using idea.properties

Hi all,

We're using Intellij Idea for most of our development work and recently a colleague created a plugin for Intellij Idea.
I've read up on distributing this plugin within te company, specific using the Enterprise Plugin Repository as explained on:
http://www.jetbrains.com/idea/webhelp/adding-plugins-to-enterprise-repositories.html
and
http://www.jetbrains.com/idea/webhelp/managing-enterprise-plugin-repositories.html

I've configured a webserver to host a repository and created an updatePlugins.xml
When I try to add the plugin-repository using steps 1 - 7 as described on the second link it works like a charm.
The plugin is discovered, can be installed and is usable.
I've also noticed the alternative option:

As an alternative, you can specify the list of URLs for the enterprise plugin repositories in the                 idea.properties file.                 This file is located in the IntelliJ IDEA installation folder in the                 bin directory.

Open the file and add the following line:

-D idea.plugin.hosts=[URL1],[URL2],...[URLn]

where                 [URL1],[URL2],...[URLn] is a comma-separated list                 of the corresponding URLs.

I've tried to setup this on an install here with the same url I've used in the manual setup.
With or without the -D option, tried adding it to idea64.vmoptions, surrounding the url with ", specifically pointing to the properties file like:
IDEA_PROPERTIES=/opt/idea-ic/bin/idea.properties idea-ic
when starting intellij idea. It all leads to the same result,... not having the extra repository.

Somehow it looks like the plugin repository is not being picked up. We have both the ultimate edition and community edition. When trying this I've used the community edition.

I hope someone has an idea on how to do this correctly because at this point I'm at a loss....

Thanks in advance!

7 comments
Comment actions Permalink

Hi,

-Didea.plugin.hosts=URL1;URL2

should be provided in idea.vmoptions file (http://www.jetbrains.com/idea/webhelp/tuning-intellij-idea.html). Please note that list is semicolon (;) separated.

We'll update help accordingly.

Thanks,
Anna

0
Comment actions Permalink

Anna,

Thank you for your response.
I have tried to implement the solution you provided however I still can't locate the plugin the repository provides.
I have added the -Didea.plugin.hosts=http://company.intranet.url/path to the idea64.vmoptions.

When I start Idea I also see it in my process listing:
/usr/lib/jvm/java-7-oracle/bin/java -Xms128m -Xmx750m -XX:MaxPermSize=350m -XX:ReservedCodeCacheSize=96m -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -Djsse.enableSNIExtension=false -XX:+UseCodeCacheFlushing -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -Dawt.useSystemAAFontSettings=lcd -Didea.plugin.hosts=http://company.intranet.url/path -Djb.vmOptionsFile=/opt/idea-ic/bin/idea64.vmoptions -Xbootclasspath/a:/opt/idea-ic/bin/../lib/boot.jar -Didea.paths.selector=IdeaIC13 -Djb.restart.code=88 com.intellij.idea.Main

It clearly is picked up @ start, but within Settings -> Plugins it's nowhere to be found...

Do you have any suggestions?

0
Comment actions Permalink

I just tried it. That parameter works, but it can be used only for updating existing plugins via Help | Check for update, nothing more.

0
Comment actions Permalink

It was used in check for updates only. I've changed the behaviour slightly so you would see configured repositories in UI, though you won't be able to edit them.

Anna

0
Comment actions Permalink

Anna,

Thanks, I thought it was the same behaviour as the manual way. Not only for update-checks.
But visible and not editable would be a nice solution!
This will be included in a future release I presume?

Lammert

0
Comment actions Permalink

Yes, should appear in IDEA 14 EAP. Thanks

0
Comment actions Permalink

Thanks for your help!


0

Please sign in to leave a comment.