FTPS suddenly stopped working


I have been using ftps implicit connection over port 990 to deploy to our server, but in the last couple days it stopped working.  I got the error message "Connection to domain.com failed.  Could not connect to FTP Server on domain.com".  I have tried rebooting and re-creating the ftp profile, but that didn't help.  I am able to connect with the same ftps setting using two other ftp clients, so there is probably no problem with the server.  I am also able to connect using plain ftp on port 21.  There has not been any software updates.  Only unusual thing is that I was travelling and connected to a hotel's wifi.   Can't remember if I used the ftp to connect (don't think so), but certainly since I got back I have not been able to connect.

Any help is appreciated.  Thank you.

ps.  I am running Idea 13.1.4 with Java 7.  I have tried the following command without any success.

netsh advfirewall set global StatefulFtp disable
Comment actions Permalink


Do any related errors or exceptions appear in idea.log right after the failed actions? (Use main menu / Help / Show Log if you don't know where the log is.)


Comment actions Permalink

Thanks Alexander.  That's a helpful hint.  I found this when I opened the log:

javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateExpiredException:


Please sign in to leave a comment.