How to use android.support.v8.renderscript for renderscript in the auto generated files?

. I read everywhere that I should use android.support.v8.renderscript instead of android.renderscript. I have a big problem with this, because when I want to create a new ScriptC_???(mRS) it demands a android.renderscript.RenderScript variant(mRS) and I can't find a constructor with the other packet RenderScript version. It seem that in the automaticly generated files, it uses that package too(android.renderscript). So to use the renderscript I wrote, I need a android.renderscript.Renderscript variant to inicialize, because the automaticly generated .java files don't accept the support.v8.renderscript.Renderscript variants.

( I created an asd.rs file and from that it generated a ScriptC_asd file, in that file there is only 2 constructor and both needs a android.renderscript.RenderScript. In that file there is a android.renderscript.* import but I can't change that)

How could I make it to use the support.v8 package?

2 comments
Comment actions Permalink

Unfortunatelly Renderscript support mode is not supported for old-style IntelliJ projects. It is now available for Gradle-based (Android Studio style) projects only.

0
Comment actions Permalink

Thank you, great to know.

0

Please sign in to leave a comment.