Completion in Java comment

When I am adding a @link tag in a javaDoc comment, IDEA helpfully provides completion for the class name.  However, it always seems to resolve to the full class name with the entire namespace.  This isn't necissary as the @link tag respects imports in the file.  If I remove the full namespace, the link still works correctly.

Is there any way I can get IDEA to stop expanding the entire class name, it is rather annoying to have to delete it manually for every link tag I enter.

2 comments
Comment actions Permalink

Turn off File > Settings (Ctrl+Alt+S) > Code Style > Java > [Imports Tab] > "Use fully qualified class names in javadoc"

0
Comment actions Permalink

That did it.  Thanks for the help.

0

Please sign in to leave a comment.