Ubuntu 9.04: IDEA 8.1 stops the GUI when hitting a breakpoint

I'm using IDEA 8.1 (build 9732) on Ubuntu 9.04, Java 1.6.0_13. It now happend two times, that when IDEA hit a breakpoint in the debug session, the whole desktop became unresponsive. Fortunately, I could switch to console using Ctrl+Alt-F1 and kill the first of the two Java processes. After switching back with Alt-F7 the IDEA window was gone and the desktop responsive again.

Is this a know problem or might it be caused by my particular system?

Thanks,
Tom

15 comments
Comment actions Permalink

it seems like other people have same problems, see  one of the last comments here:
http://www.jetbrains.net/jira/browse/IDEADEV-2359

0
Comment actions Permalink

actually, they have other problems  (not freezing, but keyboard not reacting)

0
Comment actions Permalink

OK, this issue seems to be gone with the latest EAP build.

0
Comment actions Permalink

No, it happend again with build 9821.

0
Comment actions Permalink

I find that problems like this occur if you install the JDK with APT.
However, the problems seem to go away if you download the JDK from the Sun site and extract it yourself and set JAVA_HOME in your bash_profile.

I am using  Linux Mint 6 (based on Ubuntu 8.10) with IDEA build 9821.

0
Comment actions Permalink

I believe using apt installs Open JDK, now, I don't know what the difference is with Sun JDK

0
Comment actions Permalink

Can it be this issue:
http://www.jetbrains.net/jira/browse/IDEA-13020
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6384219
?


Yes, it sounds like the one I've hit. Is it IDEA-JDK or application-JDK
dependent? If the latter one, I could use Java 1.5 instead.

Tom

0
Comment actions Permalink

> Is it IDEA-JDK or application-JDKdependent?
Good question. I do not remember this for sure, and it looks like two links I gave speaks the opposite at this point. Please, try to vary at least one parameter.

Alexander.

0
Comment actions Permalink

Hi,

I'm experiencing the problem too with the Sun jdk (installed with apt-get, but it's not the OpenJDK version) : java-6-sun-1.6.0.13

It's now impossible to put a breakpoint on a GUI event. I've tried the workaround found in the Sun bug database :

Section "ServerFlags"
    Option "AllowDeactivateGrabs" "on"
    Option    "DontZap"    "False"
EndSection


but it seems that the "AllowDeactivateGrabs" options has been removed from the X server bundled with Jaunty

I've tried adding the following option to idea.vmoptions, but it does not help :

-Dsun.java2d.pmoffscreen=false

If anyone finds a workaround, I'd be glad to know about it !

Thanks

0
Comment actions Permalink

One more information : I've started IDEA with the OpenJDK, and the behaviour is exactly the same. Worse, IDEA looks ugly

0
Comment actions Permalink

I've tried to use SUN Java 1.5 instead of SUN Java 1.6 as application JDK and it seems to solve this problem.

Tom

0
Comment actions Permalink

My application requires a JDK 1.6. I tried to launch it with an alternate JRE (OpenJDK), but it didn't help either. Very annoying...

0
Comment actions Permalink

What happens if you remove the jdk with apt, then download and extract the tarball from the Sun website instead?
Don't forget to set JAVA_HOME in your bash profile and also put it in the PATH.

0
Comment actions Permalink

Don't know. I'm happy with Java 5 now.

0

Please sign in to leave a comment.