Prevent "Search in text occurences" as default

Hi all.

When searching for usage of a variable in a Scala case-class IDEA always has "searches for text occurences" checked as default.

Is there a way to permanently check this off?

Thansk.

2 comments
Comment actions Permalink

andreak wrote:

Is there a way to permanently check this off?

Not in IDEA v13 unfortunately. There were changes to the find usages in v12 and/or 13. In an attempt to remove the dialog box that always opened when find usages was invoked, find usages was changed to not include the dialog and use a set of defaults. If you want to change those defaults, you have to use the "Find Usages Settings" action. It is, IMHO, a weak name for the action. In reality it is an "Advanced Find Usages" or a "Find Usages with settings". Anyhow, for some reason, as part of that change, the "Find Usages Settings" action settings does not retain the settings between usages. Issue IDEA-120751 "Find usages" in IntelliJ 13 does not find all usages asked for that to be changed. That issue was recently fixed, but is slated for IDEA 14, currently in EAP. The fix is in the current v14 EAP build if you want to use it. (As a side note, the current v14 EAP builds are unusable for me, and maybe you, right now as the Ctrl+Tab switcher is broken. I've reported it via IDEA-127185.)

0
Comment actions Permalink

Thanks for the explaination.
The behavior in v13 is hopeless IMO. Find usages now finds all kinds of irrelevant stuff.

Using EAPs this early is no option for me as it's way to unstable and I need pretty stable Scala-support.

0

Please sign in to leave a comment.