Before my css was folded under my scss (or sass)

Before all my css was folded under my scss in my project file structure.
Is there a setting for this or has this just changed?

Before it was like
my-file.scss
   my-file.css
my-other-file.scss
   my-other-file.css



Now its
my-file.css
my-file.scss
my-other-file.css
my-other-file.scss



I want it to be as it was before :)

15 comments

A css files is folded under a corresponding scss files if the css file is generated from the scss file using File Watchers (see "Settings | File Watchers" for that).
Do you have File Watcher configured for .scss files? If yes, try to modify sccs file to triger File Watcher. Will it help?

0

It's renderd using file watcher, but it still doesn't work.

0

Then it's supposed to fold (at least after file watcher run triggered by scss file modification).
Please check "Output paths to refresh" field. It contains colon-separated paths (absolute or relative to working directory) that are refreshed after each file watcher run.
If it doesn't help, please share your file watcher settings (as a sreenshot or text description).

0

Where is the "Output paths to refresh" field?

Here is my settings:
settings.PNG

0

1. Open "Settings | File Watchers".
2. Double click your scss file watcher ("Edit Watcher" dialog will appear).
3. "Output path to refresh" is at the bottom.

0

Is that mine "output paths" if you look at my screen shot?

0

Oh, I see. In your case it's "Output paths".
Which IDEA version are you using? Maybe it's worth to try the latest one. There were several bugfixes in File Watchers.

0

Version 12.1.7

Its my work software, so im not in charge of upgrades.

0

And how come we need to pay for bug fixes? Sounds like a bad idea.

0

Try to set "Output paths" to:

$ProjectFileDir$\$FileDirRelativeToProjectRoot$\$FileNameWithoutExtension$.css


It worked for me in IntelliJ IDEA 12.1.7.

Generally, bugfixes included in minor upgrades are free of charge. Quote from https://sales.jetbrains.com/hc/en-gb/articles/200545411-4-Does-my-license-qualify-for-a-free-upgrade-

Licenses with valid upgrade subscriptions qualify for free upgrades to all versions released during the subscription term.
For IntelliJ IDEA and ReSharper, version-based licenses are only valid for minor upgrade and bug-fixes. Major releases do require an upgrade purchase.

0

there is no css file called that

it could be that

main.sccs => main.css

component.scss  (included in main) so if i save component main.css is rendered.

But it doesnt work even if I save main.scss. Like i said. This worked before, then suddently it didnt work. So I dont think its output paths thats the problem.

0

Please try the attached project (compass-sample.zip). It already contains configured scss compass file watcher (but you need to specify correct path to compass.bat).
Try to edit "sass/base.scss" and press Ctrl+S. Will "sass/screen.scss" contain folded "sass/screen.css"?
It worked for me (IDEA 12.1.7, Linux).



Attachment(s):
compass-sample.zip
0

So it works in your project, but even if we have the same setting in the file watcher. It doesnt work in my project. So i guess its not the file watcher setting that causes this.

0

OK, the sample project works for you too. Good.
What is "Output paths" value of your scss file watcher?
Can you attach here a sample project that doesn't work for you? That would allow me to find out the difference between two projects.

0

Please sign in to leave a comment.