IDEA 13.1.3: How to stop autocomplete in comments?

I've been writing a lot of JSDoc in .js files recently, and in /** comment blocks, IDEA 13 insists on autocompleting
my words with functions that are in my library collection.  And it's fast -- typing 'the' and hitting enter to wrap to a new
line is enough to replace 'the' with "toHex" (ToHEx, apparently), with no observable delay.  It is rage-enducing.

Here are my code completion settings:
http://i.tomfro.st/rV0LL.png
How can I stop this from happening in comments, without giving it up in the code?

6 comments

Hello Tom,

It should be already fixed: http://youtrack.jetbrains.com/issue/WEB-11108.
Do you use the latest IDEA version: http://confluence.jetbrains.com/display/IDEADEV/IDEA+13.1+EAP?
If the issue still occurs please attach idea.log ("Help - Show Log in...").

0

Hi Yaroslav, thanks for getting back to me!

I appear to be using the latest IntelliJ.  My build number matches the one on the EAP page.  See screenshot: http://i.tomfro.st/jzWMm.png

This screenshot is of the error happening in that version: http://i.tomfro.st/kky3T.png

Attached is my idea.log, since my latest startup.

Thanks again!



Attachment(s):
idea.log.zip
0

Tom,

Please try to disable all third party plugins and check the issue once again.

0

The culprit seems to be installing the sources of the Node.js core modules for Node.js code intelligence and completion (http://i.tomfro.st/yqoXX.png).  Once this is done, autocomplete turns on in comments.

Is this something that I need to track down the developer(s) of the Node.js plugin to address, or is there something I can easily do about this?

Thanks!

0

Please sign in to leave a comment.