Is Javascript debugging supported in Firefox?

Hi there :-)

Has anyone managed to get the IntelliJ Javascript debugger running under Firefox?

It seems fine under Chrome, but when I attempt to launch the web app with Javascript debugging in Firefox, it just runs Chrome.

Reading the help pagesl, it looks like Firefox is supported. Is that not the case?

Thanks in advance


Ray

15 comments

Sure it's supported (much worse than Chrome though). Did you select FireFox in your Run configuration? Can you preview your .html files in FireFox using Alt+F2?

0

I can preview it from 'Open in Browser ...'

Yes, I have selected Firefox in the run config; it just launches Chrome.

Mmmm, the IE selection launches Chrome as well.

0

Do you have JetBrains FireFox extension installed (can you see it  in Tools/Add-ons/extensions)? What is your FireFox version? Do you have a single FireFox version  installed?
Please try enabling debug logging for  #com.intellij.firefoxConnector.configuration.FirefoxExtensionUtil and  #com.intellij.ide.browsers.firefox.FirefoxUtil categories (http://devnet.jetbrains.com/docs/DOC-1202), recreate the issue and attach the generated idea.log

0

Ah.

I don't seem to have that extension installed.

Where do I get it? Doesn't seem to show up in searches.

0

you do not normally need to install it manually - it should be  installed automatically the first time your start debugging. What is  your FireFox version? Do you have a single FireFox version installed?
You can try installing the extension manually. It's bundled  with Idea - plugins/JavaScriptDebugger/extensions/jb.xpi. See http://www.accessfirefox.org/Install_Addon_Manually.php for some instructions

0

I'm using Version 29.0.1 and it's the only version installed on my machine.

I did read that the plugin was supposed to install automatically, but I've never seen it work.

I'll try installing it manually and see what happens.

:-)

0

Mmm. Weird.

Okay, the plugin is installed (version0.6.1) and I tried it again.

It still starts Chrome. I'll disable the Chrome add-on and see what happens.

Here's the log file.



Attachment(s):
idea (2).log.zip
0

Switched off the Chrome extension, and it still launches Chrome - without any debugging at all.


0

Nothing special in the log. Please can you enable debug logging as I asked in my first comment?
Please also attach a screenshot of your Settings/Web Browsers page. Is FireFox your default browser?

0

Yup, the log I sent is with the debug settings you sent in your first message. As you say, nothing out of the ordinary.

I'll try making Firefox the default browser.

0

Okay, setting it as the default browser didn't work, but when I disabled Chrome in the IntelliJ browser configuration, it started Firefox correctly. Unfortunately, it didn't want to debug anything. It did give me this error message in the console though:

The jsdIDebuggerService and its associated interfaces are deprecated. Please use Debugger, via IJSDebugger, instead.    chrome://jetbrains-connector/content/debugger.js


Hope that helps.

0

Yes, I see this warning as well, but debugging works despite it. I'm using the same FF and extension versions
Is the URL loaded in the browser when you start debugging?

More debug logging - please add the fololowing categories to log.xml:

<category name="#org.jetbrains.io.jsonRpc.JsonRpcServer">
<priority value="DEBUG"/>
</category>
<category name="#org.jetbrains.v8.EventMap">
<priority value="DEBUG"/>
</category>
<category name="#org.jetbrains.v8.AfterCompileProcessor">
<priority value="DEBUG"/>
</category>
<category name="#org.jetbrains.v8.connection.V8MessageDecoder">
<priority value="DEBUG"/>
</category>
<category name="#org.jetbrains.rpc.MessageManager">
<priority value="DEBUG"/>
</category>
<category name="#org.jetbrains.io.ChannelExceptionHandler">
<priority value="DEBUG"/>
</category>

restart, recreate the issue and attach your idea.log

0

Okay, is there a private address I can send this too?

0

You can try out ftp -
ftp://ftp.intellij.net/.uploads/ (anonymous login,
.uploads directory has no permissions to list/download files, only for upload,  so that other users will not be able to download your files). I'd also liie to look at your webservers configuration - please attach a screenshot of your settings


0

Hi there.

Can't seem to upload to that folder. Are the permissions right?

0

Please sign in to leave a comment.