Build 9164 - Debugger 'run to cursor' button broken

I'm debugging a unit test, and find that although I can 'run to cursor' with Alt-F9, if I press the corresponding debugger toolbar button, it gives every indication of being activated - it goes grey & loses focus, but the execution line doesn't change. I've tried this again since restarting IDEA, and it's repeatable on my installation.

All the other debugger buttons seem to work OK.

15 comments
Comment actions Permalink

Dave,
I was not able to reproduce this.
Could you please send me a test project illustrating the problem with exact instructions what actions I should perform to reproduce
the behaviour?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Dave Lorde" <no_reply@jetbrains.com> wrote in message news:10634160.13901228302807341.JavaMail.clearspace@app4.labs.intellij.net...

I'm debugging a unit test, and find that although I can 'run to cursor' with Alt-F9, if I press the corresponding debugger toolbar
button, it gives every indication of being activated - it goes grey & loses focus, but the execution line doesn't change. I've
tried this again since restarting IDEA, an
d it's repeatable on my installation.

>

All the other debugger buttons seem to work OK.

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5228117#5228117



0
Comment actions Permalink

Hi Eugene - unfortunately, this problem only seems to occur on my large work project - the button works fine in trivial projects.

It may be a symptom of lack of memory somewhere - I've seen Swing do similar things when it runs out of resources due to hitting memory limits.

The frustrating thing is that (according to the heap size indicator), the project only uses about 650 MB of 1024 MB when idle, and works fairly smoothly, but when loading or refreshing repository data from CVS, it will shoot up to 1000+ MB and repeatedly throw up the 'Out Of Memory' dialog.

0
Comment actions Permalink

that (according to the heap size indicator), the project only uses about 650 MB of 1024 MB when idle, and works fairly smoothly,
but when loading or > refreshing repository data from CVS, it will shoot up to 1000+ MB and repeatedly throw up the 'Out Of
Memory' dialog.



Could we get Post-OOM memory dump for investigation?

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"



0
Comment actions Permalink

OK, I'll try and get one next time it happens.

0
Comment actions Permalink

Unfortunately, when I next got the OOM dialog, ignored it, and pressed the Memory Dump button, IDEA froze up for a few minutes and then just vanished... the log shows a bunch of Java 'out of heap space' exceptions, but I didn't get a dump file.

Now we have pucker IDEA 8 licences, I'm going to try 8.1 (#9540). I'll let you know how things progress.

0
Comment actions Permalink

Same thing happened with build #9540 - project loaded, it was updating CVS information when the OOM dialog appeared. I pressed 'Ignore' and then the Memory Dump button, and after a few seconds IDEA disappeared. At least I got a memory dump after all...

I've attached the log file and the pid log. There are a bunch of thread dumps, but I don't know if they would be useful?

I'll FTP the memory dump to ftp://ftp.intellij.net/.uploads/ as dlorde java_pid6000.zip



Attachment(s):
idea.log
hs_err_pid6000.log
0
Comment actions Permalink

Dave,
Please add
-XX:+HeapDumpOnOutOfMemoryError
to idea.exe.vmoptions file and the dump will be created in the "bin" directory automatically by JVM.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

OK, the OOM is not consistent, and didn't appear when I reloaded after clearing the system directory, but it did appear when I tried to expand the datasource in the 'Database' panel. This produced a memory dump that I have uploaded to ftp://ftp.intellij.net/.uploads/ as dlorde_java_pid3608.zip.

I've not been able to get a CPU dump when the OOM appears.

0
Comment actions Permalink

Thanks for the snapshot, Dave.

Just to check my guess - please try to disable "XPathView" plugin and perform the operations you did. Does it make any difference?


--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Eugene, looks like your guess was right on the money!

What a huge difference - I disabled the "XPathView" plugin, and now I can quit IDEA without the OOM dialog, and I can load up my project with 768 MB heap memory without the OOM dialog.

Everything seems to be running a lot faster also. I guess I can put up with using an external XSLT/XPath tool under the circumstances...

Thanks for your assistance, I'm a happy bunny again  :-)

0
Comment actions Permalink

Thanks for the information, Dave,
We'll work on XPath plugin to make it more memory-friendly.

--
Best regards,
Eugene Zhuravlev
Software Developer
JetBrains Inc.
http://www.jetbrains.com
"Develop with pleasure!"

"Dave Lorde" <no_reply@jetbrains.com> wrote in message news:17087265.29861229087513231.JavaMail.clearspace@app4.labs.intellij.net...

Eugene, looks like your guess was right on the money!

>

What a huge difference - I disabled the "XPathView" plugin, and now I can quit IDEA without the OOM dialog, and I can load up my
project with 768 MB heap memory without the OOM dialog.

>

Everything seems to be running a lot faster also. I guess I can put up with using an external XSLT/XPath tool under the
circumstances...

>

Thanks for your assistance, I'm a happy bunny again :)

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5228843#5228843



0
Comment actions Permalink

Dave, please check the next 8.1 EAP which should fix the problem about the high memory usage in the
XSLT plugin.

Sascha

Dave Lorde wrote:

Eugene, looks like your guess was right on the money!

What a huge difference - I disabled the "XPathView" plugin, and now I can quit IDEA without the OOM dialog, and I can load up my project with 768 MB heap memory without the OOM dialog.

Everything seems to be running a lot faster also. I guess I can put up with using an external XSLT/XPath tool under the circumstances...

Thanks for your assistance, I'm a happy bunny again :)

---
Original message URL: http://www.jetbrains.net/devnet/message/5228843#5228843

0
Comment actions Permalink

Thanks Sascha, I'll try it just as soon as I can find the download link...

Can you point me to the EAP download, I don't see a link on the announcement post.

OK, found it.

Is it just me, or is this new forum system totally awful ?

0
Comment actions Permalink

Hello Dave,

it looks like the change didn't make it into yesterday's EAP build
(http://www.jetbrains.net/confluence/display/IDEADEV/Diana+EAP). I can send you the changed plugin
as a quick "patch" though. Just send me an email if you want to try it.

Sascha

Thanks Sascha, I'll try it just as soon as I can find the download link...

Can you point me to the EAP download, I don't see a link on the announcement post.

---
Original message URL: http://www.jetbrains.net/devnet/message/5229088#5229088

0
Comment actions Permalink

Aha! I wondered why it fell over in exactly the same place until I disabled the plug-in...

Yes, I'd like to try the patched version.

0

Please sign in to leave a comment.