haxe debug -- waiting for player to connect then nothing. . .

New to Haxe & Intellij.  Coming from Flash Builder 4.7.  Trying to make sure I can do everything I need to do before I spend the money for the licence.

I've set up the haxe file and have no problem running it.  But when I click debug, I get "Waiting for Player to connect" and then. . . nothing.  Godot.

I've looked at several threads in this forum, but no help so far.

In this thread:

http://devnet.jetbrains.com/message/5256592#5256592

They suggest:

- create new Flex run configuration (Run | Edit Configurations | [+] button | Flex), give it some reasonable name
- check 'Debug already running Flash player' radio button

Which would be awesome, but in the version I have (13.1.1), there is no Flex option (after the [+] button), just a "FlexUnit" option.  And that has no 'Debug already running Flash player' checkbox.

This thread also references the 'already running Flash player' option (which doesn't exist for me):
http://devnet.jetbrains.com/message/5259055#5259055

And I was unable to find anything useful in these:
http://devnet.jetbrains.com/message/5476464
http://devnet.jetbrains.com/message/5461658#5461658

I really want to make the leap to Haxe, and so I'm totally IDE shopping.  Intellij seems all sorts of slick, so I really hope this works out.  If anyone can point me in the right direction, I'd be really grateful.

Please sign in to leave a comment.