Git integration

Hi,

I notice a performance issue after activating git.

How can I fix this problem?

Thanks

Jérôme

Edited by: Jerome on Oct 30, 2008 10:37 PM

6 comments
Comment actions Permalink

Hello Jerome,

I notice a performance issue after activating git.

How can I fix this problem?


Deactivate git.

(Sorry, but it's the only answer I can give you with the information you
have provided. If you want a real answer, please specify which build of IntelliJ
IDEA you are using, which exactly operations are slow, and take a CPU snapshot
as described in http://support.jetbrains.com/kb/entry.jspa?externalID=192&categoryID=5
)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry,

I will be more verbose now.

I use the latest build 8987 of the diana release on windows xp with 4GB of memory.

The idea.exe.option is configured as follow

-Xms512m
-Xmx512m
-XX:MaxPermSize=120m
-ea
-agentlib:yjpagent=disablej2ee,disablecounts,disablealloc,sessionname=IntelliJIDEA


_The issue:_
When I don't select git as the version control for the project I don't get any performance issues.
When I select git as the version control the mouse cursor is refreshed each 1 or 2 seconds. Same comment when I want to scroll with the mouse. The windows is refreshed each 1 or 2 seconds.

I put on ftp://ftp.intellij.net/.uploads/ the following snapshot:
- 8987_jerome_30.10.2008_19.44.04-with-git.zip - cpu snapshot with git
- 8987_jerome_30.10.2008_19.43.16-without-git.zip - cpu snapshot without git


Hopefully you will find the issue.

Thanks

Jérôme

Edited by: Jerome on Oct 31, 2008 3:28 AM

0
Comment actions Permalink

Hello Jerome,

Thanks for the detailed information!

Unfortunately the CPU snapshots don't contain much useful information. In
order to record a more useful snapshot, please start capturing, do some work
for a while (at least 1-2 minutes) so that you experience the perfomance
problems, and then stop capturing the snapshot.

I will be more verbose now.

I use the latest build 8987 of the diana release on windows xp with
4GB of memory.

The idea.exe.option is configured as follow

-Xms512m
-Xmx512m
-XX:MaxPermSize=120m
-ea

-agentlib:yjpagent=disablej2ee,disablecounts,disablealloc,sessionname=
IntelliJIDEA
_The problem:_

When I don't select git as the version control for the project I don't
get any performance issues.

When I select git as the version control the mouse cursor is refreshed
each 1 or 2 seconds. Same comment when I want to scroll with the
mouse. The windows is refreshed each 1 or 2 seconds.

I put on ftp://ftp.intellij.net/.uploads/ the following snapshot:
- 8987_jerome_30.10.2008_19.44.04-with-git.zip - cpu snapshot with
git
- 8987_jerome_30.10.2008_19.43.16-without-git.zip - cpu snapshot
without git
Hopefully you will find the issue.

Thanks

Jérôme

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry,

I put a new snapshot file on the ftp named 8987_jerome_31.10.2008_08.51.01.zip

Could you check if this file could help you?

Thanks

Jérôme

0
Comment actions Permalink

Hello Jerome,

I put a new snapshot file on the ftp named
8987_jerome_31.10.2008_08.51.01.zip

Could you check if this file could help you?


Yes, I see the problem now, thanks. You aren't actually using the git plugin
which is bundled with IDEA - you're using an old version of the plugin which
you have installed under config/plugins. Please remove it, and the performance
problem will go away.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks you very much. It works.

Jérôme

Edited by: Jerome on Oct 31, 2008 5:30 PM

0

Please sign in to leave a comment.