IntelliJ 13 - javascript debugger stops on every module load

I'm trying to use the IntelliJ 13 to debug my node.js unit tests and application by remote connecting on port 5858.  I run with node --debug-brk ..., and then connect from IntelliJ.  My problem is that it stops many times before even getting to the first line of my test because everytime node loads a module requested via require() it stops on the first line of that file as if I had a breakpoint defined there.  I'm loading enough modules that I can't use it, and I've had to resort to console.log() statements to do my debugging.

I've checked in the Breakpionts window, and both the "Exception Breakpoints" and the "JavaScript Exception Breakpoints" checkboxes are unchecked.  Also, it seems to work fine if I run IntelliJ 12 instead of IntelliJ 13.  But several people on my team don't have IntelliJ 12 licenses.

Please Help!

    - Rick

4 comments
Comment actions Permalink

Could you please try IDEA 13.1 EAP (http://confluence.jetbrains.com/display/IDEADEV/IDEA+13.1+EAP)?

update: fix link to IDEA 13.1 EAP.

0
Comment actions Permalink


I didn't see any 13.1, but I downloaded and tried http://download.jetbrains.com/idea/ideaIU-133.1081.dmg.  Same behavior.

    - Rick

0
Comment actions Permalink

Please try IDEA 13.1 EAP
(http://confluence.jetbrains.com/display/IDEADEV/IDEA13.1EAP)

On 3/12/2014 9:36 AM, Rick Kilgore wrote:

Could you please try IDEA 13.1 EAP (http://confluence.jetbrains.com/display/IDEADEV/IDEA13EAP)?

>

I didn't see any 13.1, but I downloaded and tried http://download.jetbrains.com/idea/ideaIU-133.1081.dmg.  Same behavior.

>

     - Rick

>

---
Original message URL: http://devnet.jetbrains.net/message/5511124#5511124

>

0
Comment actions Permalink

Thank you, that did the trick!  :)

0

Please sign in to leave a comment.