Build 8890 Fails to Start

When I start it, I get this stack trace in the idea.log:

2008-10-10 10:05:57,160 INFO -
#com.intellij.idea.Main - -



IDEA STARTED -



2008-10-10 10:05:57,331 INFO - #com.intellij.idea.Main -
Using "FocusKiller" library to prevent focus stealing.
2008-10-10 10:05:58,660 ERROR - com.intellij.ide.IdeEventQueue -
Error during dispatching of
java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=com.intellij.idea.MainImpl$3@f3cc58,notifier=null,catchExceptions=false,when=1223658358503]
on sun.awt.windows.WToolkit@1776437
java.lang.AbstractMethodError
at
com.intellij.openapi.fileTypes.impl.FileTypeManagerImpl.]]>(FileTypeManagerImpl.java:129)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:247)
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:43)
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:41)
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$100(ComponentManagerImpl.java:57)
at
com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:99)
at
com.intellij.openapi.components.impl.ComponentManagerImpl.initComponents(ComponentManagerImpl.java:161)
at
com.intellij.openapi.components.impl.stores.ApplicationStoreImpl.load(ApplicationStoreImpl.java:15)
at
com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:182)
at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:17)
at com.intellij.idea.MainImpl$3.run(MainImpl.java:1)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:75)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:146)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:180)
at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
2008-10-10 10:05:58,675 ERROR - llij.ide.plugins.PluginManager -
java.lang.Error: ComponentSetup for component
com.intellij.openapi.components.impl.ServiceManagerImpl already registered
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:51)
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.a(ComponentManagerImpl.java:41)
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.b(ComponentManagerImpl.java:6)
at
com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentsRegistry.access$300(ComponentManagerImpl.java:37)
at
com.intellij.openapi.components.impl.ComponentManagerImpl.hasComponent(ComponentManagerImpl.java:108)
at com.intellij.idea.IdeaLogger$1.getInfo(IdeaLogger.java:7)
at com.intellij.idea.IdeaLogger.a(IdeaLogger.java:18)
at com.intellij.idea.IdeaLogger.error(IdeaLogger.java:52)
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:56)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:10)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:146)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:180)
at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)


2 comments
Comment actions Permalink

I solved this by removing third-party plugins from ~/.IntelliJIdea80/config/plugins


-Sakke

0
Comment actions Permalink

Did you then add the plugins back after getting it to start?

;ted

"Sakke Wiik" <no_reply@jetbrains.com> wrote in message
news:28793737.92911223736628590.JavaMail.jive@app4.labs.intellij.net...
>I solved this by removing third-party plugins from
>~/.IntelliJIdea80/config/plugins
>
>

-Sakke



0

Please sign in to leave a comment.