Git Error on Commit

I'm having a problem using git to commit a change.

When I run it through IntelliJ I get the error message.  There is no other information.

Error executing git commit --only -F /tmp/git-commit-msg-222753429846841566.txt -- my/dir/UserFactory.java

If I run it through the command line, it works as I expect it.

I'm using a post-commit hook to update my copyright notices and this seems to be the root cause of the problem.

Is there a way to turn up the error reporting when running git?  Is it possible that my hook is returning a non-zero value which IntelliJ is reporting as a failure?

3 comments
Comment actions Permalink

Hi Mark,

1. So, does everything work if you disable the hook?

2. Please check the log file (Help | Show Log) as well as the Console tab in the Version Control toolwindow: is the actual error message shown there?

0
Comment actions Permalink

Thanks for help Kirill.

It does work when I disable the hook and I hacked the hook to force it work.

I found that my hook is printing logging info, but it's only showing up the IntelliJ log not in the terminal/messages window.  So it made it a little harder to debug.  Is there a way to pipe messages from the hook into IntelliJ?  Right now, it's just using perl's print to write to the console.

0
Comment actions Permalink

It looks like this issue: Git commit hook error messages no longer display

It is targeted 13.1, so we hopefully will fix it soon.

0

Please sign in to leave a comment.