IntelliJ not commiting anymore

Hi all,

I was just working with IntelliJ 8792 on MacOS, and I noticed it didn't see the changes I made. So I manually refreshed, commit, but still not all changes where in. I refreshed (commandalty), and IntelliJ detected some changed, commit them, but still not all changes were in SVN!

This is the first time it ever happened, and ofcourse I cannot reproduce it. But it's bad enough to stop working with the EAP version. Anyone a suggestion??

Erik

3 comments
Comment actions Permalink

btw, commiting and updating both doesn't work anymore for me. Just upgraded to 8810, but it has the same problem: I just made some codechanges, comitted it, but IntelliJ thinks I don't have the latest version, even though the changes are made by myself (cac4ep). When I do an update, no updates are shown, and when clicking on the 'show diff' button, I get the message that the contents are identical (see attached screenshot)



Attachment(s):
Picture 5.png
0
Comment actions Permalink

Hello Erik,

do you mean that you changed a group of files, but not all of them were detected as modified in "Changes | Local"?
So the problem is with files status detection?

0
Comment actions Permalink

Hi Irina,

I also made an issue in JIRA for this, but I cannot answer your question, since I never use 'Changes | Local'.

What I did was edit a couple of files (say 10), do CTRL+K (Commit files), type a message, and press ok. All the files seemed to have been committed.

Than the problems started:
1) IntelliJ says I'm using an outdated version of the file, even though I made the changes myself.
2) Other people in my team, when updating, don't receive all the changes I made (they were not (all) in SVN)
3) Commiting again (CTRL+K) shows the same files I just committed, and more
4) After a local syncronize (ctrlalty?) even more files are detected as changed. Some of these weren't even colored 'blue' in the first place, even though I made changes to them.

Only after a command line commit (svn up, svn commit) the SVN repo got updated correctly. I reverted back to IntelliJ 7.0.4 now after trying #8810, which has the same problem.

0

Please sign in to leave a comment.