annotation processors running not supported for module cycle

I am on a MAC
Preferences->Compiler->annotations processors turned off
but suddenly I can't run a test code
message -->  annotation processors running not supported for module cycle ....
(well for sure in test context there are some module cycles ... temporarily)
blocking! I can't test my codes any more!
what to do to get rid of this pesky feature ...?



trying to describe more precisely the problem
I have a Maven module named "core"
to test this module in test directory I create a Junit code
but this test code depends on another maven Module named "startup" (that depends on "core")
so yes in test context there is a circular dependency .... but this is the only way to have a complete test automatically fired when "core " is rebuilt by Jenkins
(to run the test I can move those tests to another Module that depends on "core " and "startup" but then the automatic non-regression tests will not be run!)
But , again, why is this blocking message related to annotation processors? I don't run any and they are marked as out in the overall configuration ...
this is a very annoying blocking feature ....
thanks for any suggestion

Permanently deleted user

Hi Bernard,
According to code, such validation (which may end up with this particular message) is performed only in case when at least one module from the cycle is associated with active annotation processing configuration profile. In compiler settings please make sure that all configuration profiles are disabled, not only the "Default" one.


I'm having a similar issue. I have a Maven project and I have annotation processing completely turned off but still get this issue. I shouldn't get the error anyway. The one of two modules that it says has a cycle has a runtime scope, the other has provided scope. And, even if I add an exclusion on both dependencies in my pom to exclude the other module, I still get this error. 


Also, in the 'Maven Projects' tool window, the cycles do not show. Only in Analyze module dependencies and when trying to build. Seems like an issue with Maven project import.


Please sign in to leave a comment.