SQL Language Injection in IntelliJ IDEA 13

Hello,

I've been having some trouble getting the language injection feature to work. For example, I do a lot of Python work in IntelliJ and when I start typing a SQL query in a string literal and hit Alt-Enter, I do not get the option to temporarily inject SQL.

The same thing happens with Java code in a different; I cannot inject the SQL to the string literal for syntax highlighting.

I've made a database connection in the IDE. I don't have a "Language Injections" setting in the top-level settings window. What do I need to do to enable this? Thanks.

2 comments
Comment actions Permalink

Please check that you have IntelliLang plugin enabled.


0
Comment actions Permalink

Thank you! I thought it was a feature enabled by default but I must've disabled most of the plugins when I installed it.

0

Please sign in to leave a comment.