Update project no longer works with IntelliJ 8 on Mac !!

Even though my project is configured to use SVN, pressing Command + T no longer does anything. No exception, nothing. Also, when using the menu to update my project, nothing happens at all!

Help!!

12 comments
Comment actions Permalink

Hello Erik,

Even though my project is configured to use SVN, pressing Command + T
no longer does anything. No exception, nothing. Also, when using the
menu to update my project, nothing happens at all!


Which exactly build are you using?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

It currently fails 8769. I tried disabling most of my plugins, but it didn't matter.

I also tried to use 8M1, but I don't have a problem with that version!

0
Comment actions Permalink

btw: when I change something in my sourcefiles, I see the blue color in the left bar, and I can run a diff between the current file and the latest in SVN. However, updating AND committing both doesn't work. Updating locks the IDE for a couple of seconds, and then does nothing. Commiting is just greyed out, and is not possible at all.

0
Comment actions Permalink

Hello Erik,

It currently fails 8769. I tried disabling most of my plugins, but it
didn't matter.

I also tried to use 8M1, but I don't have a problem with that version!


Please file a JIRA issue describing the layout of directories in your project,
the location of the .ipr file and the settings you have specified in Settings
| Version Control | Directory Version Control Settings.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

You may be experiencing this:

http://www.jetbrains.net/jira/browse/IDEADEV-29639

Actually, seeing the version's it is supposedly fixed in, I guess not!

Edited by: Simon Knott on Sep 14, 2008 9:51 PM

0
Comment actions Permalink

I don't think so: I don't see the whole update dialog anymore!

0
Comment actions Permalink

I also see this with subversion. Reloading a project helps.

0
Comment actions Permalink

How do I reload the project? Opening and closing the project, you mean? Cause I tried that, but no luck...

0
Comment actions Permalink

Hello Erik, as far as I understand the problem, it is indeed http://www.jetbrains.net/jira/browse/IDEADEV-29639
happened to you.
Please use a newer build, 8792.

Sorry for inconvinience.

0
Comment actions Permalink

Hi Irina,

I just upgraded to the newest version of IntelliJ 8, but after restarting it 3 times, I'm giving up. Commiting does seem to work (at least the option isn't greyed out anymore, and the dialog appears), but pressing CTRL+T or using the menu freezes up the IDE completely, with no other opion than to kill it.

Well, it's probably the risk of using bleeding edge technology...

0
Comment actions Permalink

Could I please see the stack trace of this freeze...

and could you give some information about your VCS mappings vs modules layout, like:
1) Settings | Version Control : what is mapped to Subversion...
2) does relative path from project root to your module roots contain intermediate folders

thank you

0
Comment actions Permalink

Hi Irina,

I don't know which stacktrace you refer to, or how I retreive it. I tried restarting IntelliJ again, and now it works. I still have the feeling that it takes a really long time (a couple of seconds) for the dialog to appear. I also compared it with IntelliJ 7, and there the dialog pops up immediately, as opposed to the latest build of IntelliJ 8. I've wanted to attach a memory snapshot, but I get the message that the zip file is too large. Can I upload it somewhere?

My settings look like this:

1) Settings | Version Control : | ]]>
2) I don't understand exactly what you mean, but my project looks like this:

some folder
+ project 1
+-- module 1
+-- module 2
+ project 2
+-- module 1
+-- module 2
etc..

All of these directories are under version control, and all module directories contain a pom.xml

0

Please sign in to leave a comment.