9 comments
Comment actions Permalink

Forgot the image



Attachment(s):
7.png
0
Comment actions Permalink

Oh, this is great - downloading an older command-line SVN client for Window (1.4.8) is an issue now. Whops.
Anyone has the installation ? Would be very thankful !

0
Comment actions Permalink

Ok, found it.

0
Comment actions Permalink

Hello Evgeny,

Just installed an SVN 1.5 client ("CollabNet Subversion Command Line
Client v1.5.0 (for Windows)") from from
http://www.collab.net/downloads/subversion/

and now 8493 fails to work with it - see the image attached.


SVN 1.5 will be supported in the next EAP build of Diana.

Btw, why there's no way in IDEA to point to an SVN client or, simply
put, "svn.exe" ?


Because IDEA doesn't use a command-line SVN client.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

After installing back SVN 1.4.6 (although it's not used by IDEA) - I still have the same error (after restarting IDEA), see below.
What can I do now in order to get back the SVN support ?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

2008-06-30 15:00:56,454 INFO - ellij.openapi.vcs.VcsException -
org.tmatesoft.svn.core.SVNException: svn: This client is too old to work with working copy 'E:\Projects\Zetta\branches\Ver1.9'; please get a newer Subversion client
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:55)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:40)
at org.tmatesoft.svn.core.internal.wc.admin.SVNAdminAreaFactory.open(SVNAdminAreaFactory.java:132)
at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.doOpen(SVNWCAccess.java:344)
at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.open(SVNWCAccess.java:261)
at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.openAnchor(SVNWCAccess.java:138)
at org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.java:223)
at org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.java:174)
at org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.java:138)
at org.jetbrains.idea.svn.SvnChangeProvider.processFile(SvnChangeProvider.java:220)
at org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.java:55)
at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.a(ChangeListManagerImpl.java:211)
at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.access$700(ChangeListManagerImpl.java:242)
at com.intellij.openapi.vcs.changes.ChangeListManagerImpl$5.run(ChangeListManagerImpl.java:8)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:98)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:207)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)
2008-06-30 15:00:56,470 INFO - .changes.ChangeListManagerImpl -
com.intellij.openapi.vcs.VcsException: svn: This client is too old to work with working copy 'E:\Projects\Zetta\branches\Ver1.9'; please get a newer Subversion client
at org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.java:77)
at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.a(ChangeListManagerImpl.java:211)
at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.access$700(ChangeListManagerImpl.java:242)
at com.intellij.openapi.vcs.changes.ChangeListManagerImpl$5.run(ChangeListManagerImpl.java:8)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:98)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:207)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.tmatesoft.svn.core.SVNException: svn: This client is too old to work with working copy 'E:\Projects\Zetta\branches\Ver1.9'; please get a newer Subversion client
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:55)
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:40)
at org.tmatesoft.svn.core.internal.wc.admin.SVNAdminAreaFactory.open(SVNAdminAreaFactory.java:132)
at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.doOpen(SVNWCAccess.java:344)
at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.open(SVNWCAccess.java:261)
at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.openAnchor(SVNWCAccess.java:138)
at org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.java:223)
at org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.java:174)
at org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.java:138)
at org.jetbrains.idea.svn.SvnChangeProvider.processFile(SvnChangeProvider.java:220)
at org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.java:55)
... 11 more

0
Comment actions Permalink

Hello Evgeny,

Delete your working copy and do a new checkout with IDEA or with an old SVN
client.

After installing back SVN 1.4.6 (although it's not used by IDEA) - I
still have the same error (after restarting IDEA), see below. What can
I do now in order to get back the SVN support ?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~

2008-06-30 15:00:56,454 INFO -
ellij.openapi.vcs.VcsException -
org.tmatesoft.svn.core.SVNException: svn: This client is too old to
work with working copy 'E:\Projects\Zetta\branches\Ver1.9'; please get
a newer Subversion client
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManag
er.java:55)
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManag
er.java:40)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNAdminAreaFactory.open(SVNA
dminAreaFactory.java:132)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.doOpen(SVNWCAcces
s.java:344)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.open(SVNWCAccess.
java:261)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.openAnchor(SVNWCA
ccess.java:138)
at
org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.jav
a:223)
at
org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.jav
a:174)
at
org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.jav
a:138)
at
org.jetbrains.idea.svn.SvnChangeProvider.processFile(SvnChangeProvider
.java:220)
at
org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.
java:55)
at
com.intellij.openapi.vcs.changes.ChangeListManagerImpl.a(ChangeListMan
agerImpl.java:211)
at
com.intellij.openapi.vcs.changes.ChangeListManagerImpl.access$700(Chan
geListManagerImpl.java:242)
at
com.intellij.openapi.vcs.changes.ChangeListManagerImpl$5.run(ChangeLis
tManagerImpl.java:8)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441
)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.a
ccess$301(ScheduledThreadPoolExecutor.java:98)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.r
un(ScheduledThreadPoolExecutor.java:207)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecu
tor.java:885)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
java:907)
at java.lang.Thread.run(Thread.java:619)
2008-06-30 15:00:56,470 INFO -
.changes.ChangeListManagerImpl -
com.intellij.openapi.vcs.VcsException: svn: This client is too old to
work with working copy 'E:\Projects\Zetta\branches\Ver1.9'; please get
a newer Subversion client
at
org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.
java:77)
at
com.intellij.openapi.vcs.changes.ChangeListManagerImpl.a(ChangeListMan
agerImpl.java:211)
at
com.intellij.openapi.vcs.changes.ChangeListManagerImpl.access$700(Chan
geListManagerImpl.java:242)
at
com.intellij.openapi.vcs.changes.ChangeListManagerImpl$5.run(ChangeLis
tManagerImpl.java:8)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441
)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.a
ccess$301(ScheduledThreadPoolExecutor.java:98)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.r
un(ScheduledThreadPoolExecutor.java:207)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecu
tor.java:885)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
java:907)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.tmatesoft.svn.core.SVNException: svn: This client is
too old to work with working copy 'E:\Projects\Zetta\branches\Ver1.9';
please get a newer Subversion client
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManag
er.java:55)
at
org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManag
er.java:40)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNAdminAreaFactory.open(SVNA
dminAreaFactory.java:132)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.doOpen(SVNWCAcces
s.java:344)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.open(SVNWCAccess.
java:261)
at
org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.openAnchor(SVNWCA
ccess.java:138)
at
org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.jav
a:223)
at
org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.jav
a:174)
at
org.tmatesoft.svn.core.wc.SVNStatusClient.doStatus(SVNStatusClient.jav
a:138)
at
org.jetbrains.idea.svn.SvnChangeProvider.processFile(SvnChangeProvider
.java:220)
at
org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.
java:55)
... 11 more

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks! I think I'll just wait for a new build and use Tortoise till then.

0
Comment actions Permalink

I still hope that SVN 1.5 will be supported also in the next EAP build of Selena. I noticed that SvnKit (Subversion client library for Java used by IDEA) 1.2 beta is already available...

0
Comment actions Permalink

Hello stepand76,

I still hope that SVN 1.5 will be supported also in the next EAP build
of Selena. I noticed that SvnKit (Subversion client library for Java
used by IDEA) 1.2 beta is already available...


Yes, it will. We've started with integrating the new SVNKit into Diana, but
Selena will follow very soon.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.