Cannot checkout from SVN

Hi Community,

Please advise on the following problem:

I'm trying to checkout some code from SVN repository. But at the moment when it tries to perform checkout the following error occurs:
Funny letters are: "couldn't find specified file".

What file it tries to find?

Thank you in advance

Comment actions Permalink

Forgot to mention:

OS: Windows 7, 64bit
IDE: IntelliJ Idea 13

Comment actions Permalink


It probably tries to find svn executable. Is it installed in the system and resides in PATH? In other words, if you execute "svn" from the system command line, is the svn executable found?

See also Settings dialog / Version Control / Subversion page.


Comment actions Permalink

So currently Intellij 13 only can work with external svn command?

I tried Intellij 12, it doesn't need to install any external svn command and works soomthly with internal svn which integrated in intellij 12.

I did a clean install, enabled svn plugin. Got same issue with Intellij Universal/Community editon 13. But I can browser svn repository and can use export command.

There is no any document about this in Intellij 13 (whether you need install a external svn or not) and a lot people met this issue.

I tried modified any reasonable setting in the IDE, no luck.

Pls advise.

Comment actions Permalink

Same messages as Maxim Petrov when I upgrade to version 13. Same configuration as in version 12.1.6, no svn client installed. Only solution so far is to downgrade to 12.1.6.

* Windows 7 and Xubuntu 12.04 - both 64 bit.
* Ultimate edition
* Java 7

Comment actions Permalink

Upgrade to 13.0.1 today. Ok in windows 7 but error remain in xubuntu 12.04 64 bit.

Konstantin Kolosovsky
Comment actions Permalink

Could you please attach "Version Control -> Subversion" settings?
If "Use command line client" checkbox is checked, but incorrect (or empty) executable path is specified, then error (and also corresponding notification) should be shown. But if "Use command line client" checkbox is not checked, then there should be no error about incorrect command line executable (which was the fix of IDEA-117518).

Comment actions Permalink

Sorry about that. "Use command line client" was checked with svn as parameter. Now everything work perfect. Thank you very much.


Please sign in to leave a comment.