LSOpenURLsWithRole() failed with error -10810 on OS X Mavericks / IntelliJ 13

On my OS X Mavericks, with a fresh copy of IntelliJ 13 Ultimate, it fails to open when run. Just disappears immediately after being double-clicked.

If I run it in Terminal:

$ open /Applications/IntelliJ\ IDEA\ 13.app/

LSOpenURLsWithRole() failed with error -10810 for the file /Applications/IntelliJ IDEA 13.app.

The only log messages I see from Console:

04/12/2013 23:30:55.674 idea[493]: JNI_CreateJavaVM (/System/Library/Java/JavaVirtualMachines/1.6.0.jdk) failed: -1

04/12/2013 23:30:55.675 com.apple.launchd.peruser.501[163]: (com.jetbrains.intellij.63568[493]) Exited with code: 255



I have both JDK 6 and 7 installed. I tried updating to use Java 7 in Info.plist and got the same:


04/12/2013 23:31:54.381 idea[498]: JNI_CreateJavaVM (/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk) failed: -1
04/12/2013 23:31:54.383 com.apple.launchd.peruser.501[163]: (com.jetbrains.intellij.63568[498]) Exited with code: 255



IntelliJ 12.1.6 works fine. java works fine.
All of the IntelliJ 13 RCs have had this issue for me.


Has anyone ever seen this?
I can't find any real information on what it means that the JVM creation has failed.
3 comments
Comment actions Permalink

There are couple ideas about the problem:

1) delete config/preferences. please look at

http://intellij-support.jetbrains.com/entries/23358108

2) you have a problem with permissions. it can be fixed by the command:

chmod +x /Applications/IntelliJ\ IDEA\ 13.app/Contents/MacOS/idea*

3) you are trying to open Idea while the product is belong to a different user

4) delete and reinstall Idea using dmg distr.
1
Comment actions Permalink

Thanks, yes your first idea did the trick. I suppose there was some bad config lingering from previous IDEA 13 RCs. I hadn't thought it could be config just because it failed so early, but that was it! Hope this helps anyone else who searches for the problem.

0
Comment actions Permalink

@Vladimir Orlov you saved me, now IntelliJ opens again! Thank you :D

1

Please sign in to leave a comment.